summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-28 08:51:02 +0200
committerMichał Górny <mgorny@gentoo.org>2021-03-28 11:48:20 +0200
commite1d21e6982462644951ac58e265ae5fb30109397 (patch)
treeb147a41c0f5dfd4cd96c07fd5e285c74086ba7ed /dev-python/hypothesis
parentdev-lisp/gcl: clean old (diff)
downloadgentoo-e1d21e6982462644951ac58e265ae5fb30109397.tar.gz
gentoo-e1d21e6982462644951ac58e265ae5fb30109397.tar.bz2
gentoo-e1d21e6982462644951ac58e265ae5fb30109397.zip
dev-python/hypothesis: Bump to 6.8.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.8.3.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index c9eb13f98843..42e0c567db29 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -3,3 +3,4 @@ DIST hypothesis-python-6.3.4.tar.gz 9112374 BLAKE2B 78867f0ff142d6059a20c437c3fa
DIST hypothesis-python-6.4.3.tar.gz 9113616 BLAKE2B f3761a22b574edc0b001a25c836c3a845fb3a1396dbc4afc2caa1f31870793cfca8646e6b9b45386e835fce97b9bc68226018c50675931e48968e9502ad41844 SHA512 010d140538bd6a361326d00bf38a50ffbbe08adc55cc7597cf69563b5d028335493c1925bcb91f618afd87f4d754e8109776be89f229e8b25b91510fbf64d7bd
DIST hypothesis-python-6.6.0.tar.gz 9117847 BLAKE2B bb88ebee9db53f1c5753730d04e5dfe6a39ac4c5f7d534778b22b813ba188a55de6ad8a34f611f7863d1c3287be39ed7e10981e9d6ed8d8dd106688f154c3a49 SHA512 a446b4a11c6ee013225bfcd58e26efc6c9d867545d9bcf90a19468cb01fc5e2c5a7280ff9a80d4a1adbfe06dd155df6152941d5f53869d85e1d259e68a33a5e2
DIST hypothesis-python-6.8.1.tar.gz 9119495 BLAKE2B 4d98e30a04f652af79dd49e921b856124a312b63f087a6fd200282e9b0a0cd6fcad1a42a6008406bc347f21bf9cd6c5ff2db79d013987281f59365bd9d91550d SHA512 2f25e994438479b5faa15b2038146ab385445bf2722b0951ff55f324b074248d7322c4c6f3e9c659c18d0aa94150eea4c6567a7ac24debf2de4b32bab37a4dcc
+DIST hypothesis-python-6.8.3.tar.gz 9120421 BLAKE2B 9511f63aafe499316750ec8a993726d4e8db87b42fb772cf79cde1be18b23e99f55c1a2638f3ee7afadae5f323792322cf87b747ac428146fea2abc92793f8f5 SHA512 83660978dc4ff49a04d7167994821a18c769039c49dcbc515b28591651bb9ab2121e3a7267cb20281efade85003a5808e0898fda5dfe1e4be563a03d4688085c
diff --git a/dev-python/hypothesis/hypothesis-6.8.3.ebuild b/dev-python/hypothesis/hypothesis-6.8.3.ebuild
new file mode 100644
index 000000000000..75d02aad2bd3
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.8.3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 eutils multiprocessing optfeature
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' 'python*')
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+distutils_enable_tests --install pytest
+
+python_prepare() {
+ if ! use cli || [[ ${EPYTHON} != python* ]]; then
+ sed -i -e '/console_scripts/d' setup.py || die
+ fi
+}
+
+python_test() {
+ distutils_install_for_testing
+ epytest tests/cover tests/pytest tests/quality \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}