summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-04 06:36:24 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-04 07:31:15 +0100
commite8b53c46b0786fcd1fe6b0062a46cb2a18219054 (patch)
treebac925cb8c514d0d2ddc02dae3f678d8f60f1930 /dev-python/hypothesis
parentdev-python/shtab: Keyword 1.7.0 x86, #926111 (diff)
downloadgentoo-e8b53c46b0786fcd1fe6b0062a46cb2a18219054.tar.gz
gentoo-e8b53c46b0786fcd1fe6b0062a46cb2a18219054.tar.bz2
gentoo-e8b53c46b0786fcd1fe6b0062a46cb2a18219054.zip
dev-python/hypothesis: Bump to 6.98.17
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.98.17.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 26376eae94b8..97f01b9259d0 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -4,4 +4,5 @@ DIST hypothesis-6.98.11.gh.tar.gz 9428472 BLAKE2B 79c4561ac1ac3ad309bccd215bb0b4
DIST hypothesis-6.98.12.gh.tar.gz 9429362 BLAKE2B cb8ac92b93057c1e311caddcdba99ef56cc5fdcedbf4a5fc0cc9342a4bdc2565cb5154f963e202b0d6fc6254a123277db0ff825493ed0d240f01b14f33131745 SHA512 0dfb07a69810685fc8042e93ce3fa9738d593835008bae31afd9cee621b8975f455c545768096990c3000e08d230cb116c465509e95c5139db0c7609a576ab3e
DIST hypothesis-6.98.13.gh.tar.gz 9430826 BLAKE2B 93de2e3548c10167e3f1d66dafe8a1f4bb221b79da6de71055753413778657260aac88ac6321d78a06934d2e5c649478b8f7704a79d7d93bcb655d866b3c89d5 SHA512 4a512e2feea13968327913df601be284bf42f94f7cfc574db6e2107b991d83f5c81734a43df31a19f30e1ea57f610916d611270fb9c9f5df353db7c2645b6428
DIST hypothesis-6.98.15.gh.tar.gz 9431325 BLAKE2B 350791d64db933b4b64df5430d79ec1d67b6fac9f2a3cef0997965e29c2c1acc1f83e59f11591d29734abc5704a2d25f4497d30c6fce8190bd245365d8ee5dbd SHA512 97794968d2028fd1fbb90c1fcb415f3d3cc894e160f0af0a867798ffb6b678c7f5c213ef24d05def81be0fda3de4264371e211e7c514b64d5e21d312ca381ef1
+DIST hypothesis-6.98.17.gh.tar.gz 9434016 BLAKE2B 3c26f8c696bc4a62b9ada8e45dd3053879e15c3dfde25caf8239be5e89f6267df342d9c3039b6c2cbb8125ade365b89c5f4d1de5f79e65ddc0808227fe37ec40 SHA512 749fb572b7239dafab5af649ec0eb8fa0071f35dd394c1b356ff2042abbe6e469ca8d7c32619d44cefbc3d7aa8fd31a81d95f772e826578261fdf97c792bdb57
DIST hypothesis-6.98.9.gh.tar.gz 9427046 BLAKE2B c3705e4c780b6e7f427943231ac056f343e70569e88391f118383e6d6197f72e744306476f2e1994e8a6d95dce73b93dcd49e8fa197149e532b84c91bce79594 SHA512 1e8a0dcefb8def8376a0ad6549a58dac66470941e4a3584ba82867f8779fd941c141039f631f15f134f7cdb3beb2ad1a19312d8e56c47db9ace0569f203afaf3
diff --git a/dev-python/hypothesis/hypothesis-6.98.17.ebuild b/dev-python/hypothesis/hypothesis-6.98.17.ebuild
new file mode 100644
index 000000000000..f7f366381e4f
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.98.17.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+CLI_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( "${CLI_COMPAT[@]}" pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+TAG=hypothesis-python-${PV}
+MY_P=hypothesis-${TAG}
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="
+ https://github.com/HypothesisWorks/hypothesis/
+ https://pypi.org/project/hypothesis/
+"
+SRC_URI="
+ https://github.com/HypothesisWorks/hypothesis/archive/${TAG}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}/hypothesis-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-22.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/exceptiongroup-1.0.0_rc8[${PYTHON_USEDEP}]
+ ' 3.9 3.10)
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' "${CLI_COMPAT[@]}")
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/requests-toolbelt-0.10.1
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # subtests are broken by warnings from random plugins
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,_hypothesis_pytestplugin
+ local -x HYPOTHESIS_NO_PLUGINS=1
+
+ # NB: paths need to be relative to pytest.ini,
+ # i.e. start with hypothesis-python/
+ local EPYTEST_DESELECT=()
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ # failing due to warnings from numpy/cython
+ hypothesis-python/tests/pytest/test_fixtures.py::test_given_plus_overridden_fixture
+ )
+ ;;
+ esac
+
+ epytest -o filterwarnings= -n "$(makeopts_jobs)" --dist=worksteal \
+ tests/cover tests/pytest tests/quality
+}
+
+python_install() {
+ distutils-r1_python_install
+ if ! use cli || ! has "${EPYTHON}" "${CLI_COMPAT[@]/_/.}"; then
+ rm -r "${ED}/usr/bin" "${D}$(python_get_scriptdir)" || die
+ fi
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}