summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-05 09:18:43 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-05 10:28:42 +0200
commitf06f812439b4fcc718d03cc28dd382b2710188fa (patch)
treeae14ef30fea41d629b372d8165771f934ab4b59b /dev-python/hypothesis
parentdev-python/stripe: Bump to 2.58.0 (diff)
downloadgentoo-f06f812439b4fcc718d03cc28dd382b2710188fa.tar.gz
gentoo-f06f812439b4fcc718d03cc28dd382b2710188fa.tar.bz2
gentoo-f06f812439b4fcc718d03cc28dd382b2710188fa.zip
dev-python/hypothesis: Bump to 6.13.14
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.13.14.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index d59f3bf32796..435e91e3b359 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -4,6 +4,7 @@ DIST hypothesis-python-6.13.10.tar.gz 9132876 BLAKE2B fb9b48465fd6e6ce0842338475
DIST hypothesis-python-6.13.11.tar.gz 9133504 BLAKE2B b9cb54dc05aafd57424a2f9fff097a66e3ba5e55408f8a4587eb7aee079f1ad494e3a9cc18a7797c09fa4444715290dc49c58b98e722dc0722d8cad0d6cbbe0d SHA512 9cb8ce31a7062ab98db829300c1f68e1e24bf02a39ebf4ffbbf47554741dd0bdb96edd69aa7a360570405ca85b1fd7956eb26c5b9a6898f6f8f6f79177522bf6
DIST hypothesis-python-6.13.12.tar.gz 9133873 BLAKE2B 161e323d9dad6d6a91641336b6e66fe0b00bcc902d844480ed0cea59b89c455eaaf8f57122636af464719d63cf96d0dfeb42dbd855d5599856636b4f4e1520bd SHA512 e58d9a676b9f6592134f4f4997d7585001c28980697e77f8f3216c5bba65256c15784e7eec5458f58684b61cc5a0d9ef2465748412a601a867a70e5b72fde91d
DIST hypothesis-python-6.13.13.tar.gz 9133621 BLAKE2B b21d2b566aac70d30abd8dbd96aafbe0f16b9d4cfe997d88bbd36724bd90ba7c747c87275d47d977a065431c87a5b75814a774fa34c9360f973829382e94e6d2 SHA512 87564b6b1d3c917d50feb1ee3b0f3f16fb880d42f8226f50ede28b175471b65cac4286d0569d4a33c82f5924df7941c0b2b49862f9e79fc851ec4d3e556a2a2d
+DIST hypothesis-python-6.13.14.tar.gz 9134690 BLAKE2B 821fa0baa47dd896fc5ec61d0a96fec3da225dbc35306e6cf684641262c9ff0b714ca95aff69daca4bda551033a67d90b411f0cc2abff8edd41e5d749939344f SHA512 74397fd77e6e70df918e0fa605180e2bfd509fb26ef8b4a86020524611a315950073c3babd65bb2d2ff65d39e027bc52da88c0125f422cc2493076398e733853
DIST hypothesis-python-6.13.2.tar.gz 9130008 BLAKE2B 3ca5c306ac402002a1435b8ccbc034f2a7acf1553eb6095e0394ff1ddf778f47ef6f72359cb5219db924edc18623b22732b4a94bd7c269217ec632b8d59adc1c SHA512 8c7e1a5de011ef66f5105009aa82f2b23ff36f0b0906554ae65e2e55e10c4df743c894b6264002c86bae3fc5e1dd7ded7e913f0866ed725e1afd4c9f54022b7c
DIST hypothesis-python-6.13.4.tar.gz 9130435 BLAKE2B eeb78cc647df49ea11fb0e0f4d8412e20095e7c33bb0601dcbaad2b9e9929423729b25b1bfbf2a27b05e87ae38ced4e9aeba5bae4de76cfc81aae2d073248de0 SHA512 93db99bdbe408ddbad4baf983b00b3e7624fd28d15a0d4c1453437328a51b0733db13e3b7b04b40bc60aa05e2e8364ce5b186d81a2d33e50b49f5a406fec95d6
DIST hypothesis-python-6.13.5.tar.gz 9131314 BLAKE2B 3de7ba681ab9c0907920ea7ad562a4434f06009a7bced47b98bf46da5d15aea35085350f4aca24fd41ba9fd14957e4de1d56092d49e757ea60a1575f59371add SHA512 06765607be1a49d92382d426105021ed9dca91c5b41674ba45f0a29ce7cb06537edf706ea7305300f9aae7d8c9b1827bcaf807e3c4aece9594a55b3c0122c622
diff --git a/dev-python/hypothesis/hypothesis-6.13.14.ebuild b/dev-python/hypothesis/hypothesis-6.13.14.ebuild
new file mode 100644
index 000000000000..004d0d143b20
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.13.14.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' python3_{7..9})
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!dev-python/pytest-describe
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+distutils_enable_tests --install pytest
+
+python_prepare() {
+ if ! use cli || ! has "${EPYTHON}" python3_{7..9}; then
+ sed -i -e '/console_scripts/d' setup.py || die
+ fi
+}
+
+python_test() {
+ distutils_install_for_testing
+ epytest tests/cover tests/pytest tests/quality \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}