summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-23 16:49:55 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-23 18:34:14 +0200
commitf4044727d962b753251889baa0f6c8e8b58001bf (patch)
tree288929a6033eff2fe77d83d81a99a178e89d2d3a /dev-python/hypothesis
parentapp-emulation/wine-staging: Drop old (diff)
downloadgentoo-f4044727d962b753251889baa0f6c8e8b58001bf.tar.gz
gentoo-f4044727d962b753251889baa0f6c8e8b58001bf.tar.bz2
gentoo-f4044727d962b753251889baa0f6c8e8b58001bf.zip
dev-python/hypothesis: Bump to 6.13.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.13.2.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 6588afec157d..f1f80172faa6 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -1,2 +1,3 @@
DIST hypothesis-python-6.10.1.tar.gz 9126246 BLAKE2B cc8cb3436d1de5d3d65a13cb5edefdbaae8bf9daed296eea9111ac46c002c34f43119f10b2ab1f45c5cbca5fe46d00738676290eb0e8437f2c10b5926d9e0915 SHA512 586b7f380cb850089f7d5321f11da92ef4a9b80e2ea925103e29c1f6c6c9da0a2a899a1a45ce77e0a40073f147561bc4fcbd5cb2ce77a9c0c65f6f64dfe4b716
DIST hypothesis-python-6.13.0.tar.gz 9128293 BLAKE2B be618d42639602bc6617f8b5e9374812298e9d6150b6510a8060ca7c489ea69f1d6bd2cf9322c325c9bffc3c3f886fb4a4fb038159fa2c81920541ac4cb668cd SHA512 66fd6e7842b7b257c92cf756db4cf97bfb64006c89e3e58cda154ebe9345302f0264297df8d9de0685033a0f4e43909d65e76495689a8ded9968ecda586b668c
+DIST hypothesis-python-6.13.2.tar.gz 9130008 BLAKE2B 3ca5c306ac402002a1435b8ccbc034f2a7acf1553eb6095e0394ff1ddf778f47ef6f72359cb5219db924edc18623b22732b4a94bd7c269217ec632b8d59adc1c SHA512 8c7e1a5de011ef66f5105009aa82f2b23ff36f0b0906554ae65e2e55e10c4df743c894b6264002c86bae3fc5e1dd7ded7e913f0866ed725e1afd4c9f54022b7c
diff --git a/dev-python/hypothesis/hypothesis-6.13.2.ebuild b/dev-python/hypothesis/hypothesis-6.13.2.ebuild
new file mode 100644
index 000000000000..22d9efb5231d
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.13.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' python3_{7..9})
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!dev-python/pytest-describe
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+distutils_enable_tests --install pytest
+
+python_prepare() {
+ if ! use cli || ! has "${EPYTHON}" python3_{7..9}; then
+ sed -i -e '/console_scripts/d' setup.py || die
+ fi
+}
+
+python_test() {
+ distutils_install_for_testing
+ epytest tests/cover tests/pytest tests/quality \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}