summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-29 09:29:00 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-29 10:06:48 +0200
commitf4250ca600c7b10e10af526d5ada313c6b835b70 (patch)
tree5186b38a78c93b5abac2ca91d0df907856241cb7 /dev-python/hypothesis
parentdev-python/execnet: Bump to 1.8.1 (diff)
downloadgentoo-f4250ca600c7b10e10af526d5ada313c6b835b70.tar.gz
gentoo-f4250ca600c7b10e10af526d5ada313c6b835b70.tar.bz2
gentoo-f4250ca600c7b10e10af526d5ada313c6b835b70.zip
dev-python/hypothesis: Bump to 6.13.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.13.8.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 37a9fc3115e9..d9cbd2864a4f 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -5,3 +5,4 @@ DIST hypothesis-python-6.13.4.tar.gz 9130435 BLAKE2B eeb78cc647df49ea11fb0e0f4d8
DIST hypothesis-python-6.13.5.tar.gz 9131314 BLAKE2B 3de7ba681ab9c0907920ea7ad562a4434f06009a7bced47b98bf46da5d15aea35085350f4aca24fd41ba9fd14957e4de1d56092d49e757ea60a1575f59371add SHA512 06765607be1a49d92382d426105021ed9dca91c5b41674ba45f0a29ce7cb06537edf706ea7305300f9aae7d8c9b1827bcaf807e3c4aece9594a55b3c0122c622
DIST hypothesis-python-6.13.6.tar.gz 9132027 BLAKE2B 939c7b410bef3d8e38a513e55f462f72cc758b78d8c76031f382969e0a622585b6f42b35a5eb70879e8cc80ea9795c5ad2d91dd55c1d3a60035e6f8e982a46d1 SHA512 dd53352df352e12f8bb9294d4e679518eff3a4431e0ccdc7037713cc3acda6d9b3da3ad2cb7748021b3acbb1b2cfe0d76fac22de68d2a020f293073ad2ce80bd
DIST hypothesis-python-6.13.7.tar.gz 9132167 BLAKE2B a7f58630d114743a04665d245384d3b5f6a0592d03a9b7e771ceb3ad8633fdd9c437dc6fa099d9dc48225d5d113a203a62ca29f50ff76fdbeb406f2cc63f9013 SHA512 70022d90c09f9478df94986059cbb986e35cb24d3a8c19d023a5a78c9e12982e196d258149456d6d2f01646e84a5ef07714f1967c6b31b53ad5e41ab2b5375d3
+DIST hypothesis-python-6.13.8.tar.gz 9132344 BLAKE2B 8de45b42711f39fc6f08f0621ba0de5977bb10d623f08565840ce7b922a7049adf29c3f9315f4c2515229a9b7419d0671112562afe1065a156bc4685ffaa92f6 SHA512 a1fe1bdfac6694ecbbe6cd0d7e3d04766d9be812ea637c6b5755fbbaceda326300043b340558c80f082460e606742b0075a751f0f9cd8edc61fd8da947bda9f8
diff --git a/dev-python/hypothesis/hypothesis-6.13.8.ebuild b/dev-python/hypothesis/hypothesis-6.13.8.ebuild
new file mode 100644
index 000000000000..22d9efb5231d
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.13.8.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' python3_{7..9})
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!dev-python/pytest-describe
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+distutils_enable_tests --install pytest
+
+python_prepare() {
+ if ! use cli || ! has "${EPYTHON}" python3_{7..9}; then
+ sed -i -e '/console_scripts/d' setup.py || die
+ fi
+}
+
+python_test() {
+ distutils_install_for_testing
+ epytest tests/cover tests/pytest tests/quality \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}