summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-19 18:53:44 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-19 21:09:23 +0100
commitf8537d789283a1932b0ff4072a72ac0637926da1 (patch)
treed59238ce37be47e4d17dd8c16483d39601e7dafa /dev-python/hypothesis
parentdev-python/sqlglot: Bump to 23.0.1 (diff)
downloadgentoo-f8537d789283a1932b0ff4072a72ac0637926da1.tar.gz
gentoo-f8537d789283a1932b0ff4072a72ac0637926da1.tar.bz2
gentoo-f8537d789283a1932b0ff4072a72ac0637926da1.zip
dev-python/hypothesis: Bump to 6.99.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.99.9.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 69e4cdb4ee59..ce496ed6d0a4 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -9,3 +9,4 @@ DIST hypothesis-6.99.5.gh.tar.gz 9441876 BLAKE2B ab1cce09dda83a89e63aaf6a995816b
DIST hypothesis-6.99.6.gh.tar.gz 9445919 BLAKE2B ea518d35aa62eb23b6859965ee5acadb12e1e6eec1e5c04b98aef5fec6f4b4e97f3c98f7c16bd07cc1e74d41040a9eabb6091c24c7132cefc2f02a94d3fe9df4 SHA512 d78c9086a6e5de8b80ec544047d70436053934a3f2b822f8389881e3679b1b7c6a26f653723f97ecf4c462b91183c35f07ffa79e6126e03926507981a6893e19
DIST hypothesis-6.99.7.gh.tar.gz 9446140 BLAKE2B 968bff89e90b2d2af67d2dd30872238d71296e1582fb9e44152c59fc9b1c26c6fd3eb2eef75a65cf51b007264f714042721a2c44304064b2540df9cc064fdd0a SHA512 484ff8d680c3b5441647dcb0e1c2ae0eff80358168f96cf8a0d3caabf8ba0159a27bffe5b118fc2f36accbec4c99be63e56f0851f1c12ebba8d26ee2bf030d70
DIST hypothesis-6.99.8.gh.tar.gz 9447084 BLAKE2B f0641ed13bbf28999294836f1faedf63428448221e9446ce87504e5446f834280d7466c79c498ce6f34613f6f0d6345a4f2d50f2aebc23c830c4265dd7b3166a SHA512 138ded3e11c3ade5fb06778929e9e49e114b9e139d6253b7d20625b31098ed30cc7ba95eb3851a6501b6c4f1426461e22dfc6fbf52fc55da7083d5412d6f1164
+DIST hypothesis-6.99.9.gh.tar.gz 9448274 BLAKE2B 9fb6732d3a3a7b2efb123f7dc09e495ad8901085e7c3aa6ab84af96fe59802246a26f1029d8e3340dfe8cdd49864a34a30d3fbb02c7a606f0758737ee6fd6893 SHA512 28a0665c2af3f3929f1d1ce3fe1f6d05a76451a30e0485abdfc8c5332f728b4a3e7216a8012ce6c4a513a33233ef68e650775aa0372f7c6cfb102fb0a239a9cd
diff --git a/dev-python/hypothesis/hypothesis-6.99.9.ebuild b/dev-python/hypothesis/hypothesis-6.99.9.ebuild
new file mode 100644
index 000000000000..f7f366381e4f
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.99.9.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+CLI_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( "${CLI_COMPAT[@]}" pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+TAG=hypothesis-python-${PV}
+MY_P=hypothesis-${TAG}
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="
+ https://github.com/HypothesisWorks/hypothesis/
+ https://pypi.org/project/hypothesis/
+"
+SRC_URI="
+ https://github.com/HypothesisWorks/hypothesis/archive/${TAG}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}/hypothesis-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-22.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/exceptiongroup-1.0.0_rc8[${PYTHON_USEDEP}]
+ ' 3.9 3.10)
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' "${CLI_COMPAT[@]}")
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/requests-toolbelt-0.10.1
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # subtests are broken by warnings from random plugins
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,_hypothesis_pytestplugin
+ local -x HYPOTHESIS_NO_PLUGINS=1
+
+ # NB: paths need to be relative to pytest.ini,
+ # i.e. start with hypothesis-python/
+ local EPYTEST_DESELECT=()
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ # failing due to warnings from numpy/cython
+ hypothesis-python/tests/pytest/test_fixtures.py::test_given_plus_overridden_fixture
+ )
+ ;;
+ esac
+
+ epytest -o filterwarnings= -n "$(makeopts_jobs)" --dist=worksteal \
+ tests/cover tests/pytest tests/quality
+}
+
+python_install() {
+ distutils-r1_python_install
+ if ! use cli || ! has "${EPYTHON}" "${CLI_COMPAT[@]/_/.}"; then
+ rm -r "${ED}/usr/bin" "${D}$(python_get_scriptdir)" || die
+ fi
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}