summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/id3-py
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/id3-py')
-rw-r--r--dev-python/id3-py/Manifest1
-rw-r--r--dev-python/id3-py/id3-py-1.2-r1.ebuild17
-rw-r--r--dev-python/id3-py/id3-py-1.2.ebuild22
-rw-r--r--dev-python/id3-py/metadata.xml8
4 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/id3-py/Manifest b/dev-python/id3-py/Manifest
new file mode 100644
index 000000000000..fc98fa3c955d
--- /dev/null
+++ b/dev-python/id3-py/Manifest
@@ -0,0 +1 @@
+DIST id3-py_1.2.tar.gz 16650 SHA256 ba612342b59a49cbf9a7eb23a646667757ffda96dc23b67245fc6cd8d90c2022 SHA512 d629a964e9008be1645815d659b45b2c1cbecc4cb5c51624adb733e0a847198848afb3959f2342df9077ce01ee1f546997639c56bfc357fa9ceec7d01da8d4fd WHIRLPOOL bbc4503ecaace0d087f3f747288b8f4ea4896889fb38695b53f1813f5b3ac258045831d522ae7b4da1d8d632a1c1dd78d01d23770a0128151f0acf96cc0a9bae
diff --git a/dev-python/id3-py/id3-py-1.2-r1.ebuild b/dev-python/id3-py/id3-py-1.2-r1.ebuild
new file mode 100644
index 000000000000..c6ff86dd32b4
--- /dev/null
+++ b/dev-python/id3-py/id3-py-1.2-r1.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Module for manipulating ID3 tags in Python"
+SRC_URI="mirror://sourceforge/${PN}/${PN}_${PV}.tar.gz"
+HOMEPAGE="http://id3-py.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
diff --git a/dev-python/id3-py/id3-py-1.2.ebuild b/dev-python/id3-py/id3-py-1.2.ebuild
new file mode 100644
index 000000000000..cc120115428e
--- /dev/null
+++ b/dev-python/id3-py/id3-py-1.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="Module for manipulating ID3 tags in Python"
+SRC_URI="mirror://sourceforge/${PN}/${PN}_${PV}.tar.gz"
+HOMEPAGE="http://id3-py.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ia64 ppc ppc64 sparc x86"
+IUSE=""
+
+DOCS="CHANGES README"
+PYTHON_MODNAME="ID3.py"
diff --git a/dev-python/id3-py/metadata.xml b/dev-python/id3-py/metadata.xml
new file mode 100644
index 000000000000..50a933a80332
--- /dev/null
+++ b/dev-python/id3-py/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="sourceforge">id3-py</remote-id>
+ </upstream>
+</pkgmetadata>