summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-03-22 01:11:06 -0400
committerTim Harder <radhermit@gentoo.org>2018-03-22 01:50:09 -0400
commite257a29253841e5d84735fd9bec17976ddb30829 (patch)
tree46042ef33a8e9a7eac7db6411d8dca48a15b64a6 /dev-python/idna-ssl
parentdev-libs/ossp-uuid: Rearrange src_prepare for eclass changes (diff)
downloadgentoo-e257a29253841e5d84735fd9bec17976ddb30829.tar.gz
gentoo-e257a29253841e5d84735fd9bec17976ddb30829.tar.bz2
gentoo-e257a29253841e5d84735fd9bec17976ddb30829.zip
dev-python/idna-ssl: version bump to 1.0.1
Diffstat (limited to 'dev-python/idna-ssl')
-rw-r--r--dev-python/idna-ssl/Manifest1
-rw-r--r--dev-python/idna-ssl/idna-ssl-1.0.1.ebuild20
2 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/idna-ssl/Manifest b/dev-python/idna-ssl/Manifest
index 2b15d7ee04ff..899bb0070a12 100644
--- a/dev-python/idna-ssl/Manifest
+++ b/dev-python/idna-ssl/Manifest
@@ -1 +1,2 @@
+DIST idna-ssl-1.0.1.tar.gz 3385 BLAKE2B a14a73b7aa79022c3831e3c66cfc31fe6f2f64474039712aabc0aac28c5ad9c98ba360bccfcacd5b37085c48c8db1f4184f7406489306dd7b87c1ac9599e8c28 SHA512 57a6891543c561cd96d35f3d01f702e8c54c592f0174f34322fd0794df8a80ad0117b558f2d0078d22cb8e0114aaa9b72c7217c91a40f02475334d7a94429c2e
DIST idna_ssl-1.0.0.tar.gz 3375 BLAKE2B 28ecee9e271619b7a4f3698aacbdbf0e953ed9b52640818007dc86f34145d8ea000260991d44cfa4cd896b74172b0a32962c3053152558b8d621396df2e248de SHA512 d1f7479cc3edff164bb26deb05af757906ba91241bc668f1b087560087a89f741a0b36e166bfb8142128ceed6008621ab36a2556ed2304ea6374c19982bc663a
diff --git a/dev-python/idna-ssl/idna-ssl-1.0.1.ebuild b/dev-python/idna-ssl/idna-ssl-1.0.1.ebuild
new file mode 100644
index 000000000000..bb91e721918b
--- /dev/null
+++ b/dev-python/idna-ssl/idna-ssl-1.0.1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Patch ssl.match_hostname for Unicode(idna) domains support"
+HOMEPAGE="https://github.com/aio-libs/idna-ssl https://pypi.python.org/pypi/idna_ssl"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/idna[${PYTHON_USEDEP}]"