summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <horea.christ@yandex.com>2016-08-29 17:11:58 +0200
committerDavid Seifert <soap@gentoo.org>2016-09-01 23:29:02 +0200
commit0c72fb7f752e9411ef03f48bd64daad849e68d82 (patch)
treed9e4b9500cc123ab85b58436d013f0421cc8c0e5 /dev-python/imageio
parentdev-lang/spidermonkey: patch 1.8.5 to build with gcc6 (diff)
downloadgentoo-0c72fb7f752e9411ef03f48bd64daad849e68d82.tar.gz
gentoo-0c72fb7f752e9411ef03f48bd64daad849e68d82.tar.bz2
gentoo-0c72fb7f752e9411ef03f48bd64daad849e68d82.zip
dev-python/imageio: new ebuild
Package-Manager: portage-2.3.0 Closes: https://github.com/gentoo/gentoo/pull/2160 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/imageio')
-rw-r--r--dev-python/imageio/Manifest1
-rw-r--r--dev-python/imageio/imageio-1.5.ebuild27
-rw-r--r--dev-python/imageio/metadata.xml21
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/imageio/Manifest b/dev-python/imageio/Manifest
new file mode 100644
index 000000000000..602fa4ac5398
--- /dev/null
+++ b/dev-python/imageio/Manifest
@@ -0,0 +1 @@
+DIST imageio-1.5.tar.gz 187004 SHA256 6240f5e8391b34bdeacf23bdb8f70c7b578dc11dec1644a6ba81b4153ad512f4 SHA512 2913353c02a26236f254c6cefce72cb8179cedeac4e1ebae435218dddfc35cbec9e806eefe99e174ca9c572c09725a697e1165f6be0bbdc657a9fcf2312c7460 WHIRLPOOL 0960f559cd47dcb0eeca2133a8118004b7fed7250da0c9a776d6745558345a59682f103bf2159e71c6f6571bed90a3879fb95d10c2af69ef83d80afe6b6c3a61
diff --git a/dev-python/imageio/imageio-1.5.ebuild b/dev-python/imageio/imageio-1.5.ebuild
new file mode 100644
index 000000000000..07d0d943e8df
--- /dev/null
+++ b/dev-python/imageio/imageio-1.5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for reading and writing image data"
+HOMEPAGE="https://imageio.github.io/"
+SRC_URI="https://github.com/imageio/imageio/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ media-libs/freeimage
+ "
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ "
diff --git a/dev-python/imageio/metadata.xml b/dev-python/imageio/metadata.xml
new file mode 100644
index 000000000000..a9976317cc48
--- /dev/null
+++ b/dev-python/imageio/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>horea.christ@gmail.com</email>
+ <name>Horea Christian</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
+ Imageio is a Python library that provides an easy interface to read
+ and write a wide range of image data, including animated images,
+ video, volumetric data, and scientific formats. It is cross-platform,
+ runs on Python 2.x and 3.x, and is easy to install.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">imageio/imageio</remote-id>
+ </upstream>
+</pkgmetadata>