summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-12 18:42:32 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-12 18:52:45 +0200
commit52a0e25eb535ae707be2544ea1bcdc0c8bf1ec91 (patch)
tree85ea0a2a39d6736c344b0dbdf1618150e9607faf /dev-python/importlib_resources
parentdev-python/importlib_metadata: Remove redundant versions (diff)
downloadgentoo-52a0e25eb535ae707be2544ea1bcdc0c8bf1ec91.tar.gz
gentoo-52a0e25eb535ae707be2544ea1bcdc0c8bf1ec91.tar.bz2
gentoo-52a0e25eb535ae707be2544ea1bcdc0c8bf1ec91.zip
dev-python/importlib_resources: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/importlib_resources')
-rw-r--r--dev-python/importlib_resources/Manifest1
-rw-r--r--dev-python/importlib_resources/importlib_resources-2.0.1.ebuild48
2 files changed, 0 insertions, 49 deletions
diff --git a/dev-python/importlib_resources/Manifest b/dev-python/importlib_resources/Manifest
index 1d1473b6b5b3..b15eabb3a070 100644
--- a/dev-python/importlib_resources/Manifest
+++ b/dev-python/importlib_resources/Manifest
@@ -1,3 +1,2 @@
DIST importlib_resources-1.5.0.tar.gz 23660 BLAKE2B aed7a2d730f945505083812355a63d3a88e07b057cf46394f3475135143e535e33dc3ebded24d233797020c805dc35decf5c5ce53758798b093f03f2951daa87 SHA512 34d14c1ff3121cc6f9ef1d3d4417831e3476e9facfcc9b35152c28a59a2c75d7723f171f4b48852f79ec46cbf54b066580745744bc54d349e2bfe12a353a9aed
-DIST importlib_resources-2.0.1.tar.gz 26060 BLAKE2B 739cd7fd90cc12b5b586eb1bf3386b85cde2399e80cfe05cae5173ba5177fb1d15f7e44e7f78473ef03e37d563861f57b7c470782d1aab161eae4c40d530ca29 SHA512 7f62c5bb5650dd2689a41ddef2e9131f01d5edc99b284a7a4257fce18190f2e78c38a2c260d6fe5e6db122666435e079c417bd9011e68e35724932854c90a1bd
DIST importlib_resources-3.0.0.tar.gz 26725 BLAKE2B e2517b0d1e576ce949ac05230892acbad59c09fa4b84401b3c957e83f40b50d12bc02360b135fe949d12c43f8f557006824e4e4a3e9ff2ce879c03362569a00c SHA512 cd29e268cacef3729024af6cae8394ce5aa8c1d8a28397fd8f009c7eaa908ed3775508bde86c26b0d233c25261b8509abb1e16c378c7c8a9bb0906224f3fdd54
diff --git a/dev-python/importlib_resources/importlib_resources-2.0.1.ebuild b/dev-python/importlib_resources/importlib_resources-2.0.1.ebuild
deleted file mode 100644
index e86acf448e78..000000000000
--- a/dev-python/importlib_resources/importlib_resources-2.0.1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# This is a backport of Python 3.9's importlib.resources
-PYTHON_COMPAT=( pypy3 python{2_7,3_{6,7,8}} )
-
-inherit distutils-r1
-
-DESCRIPTION="Read resources from Python packages"
-HOMEPAGE="https://importlib-resources.readthedocs.io/en/latest/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
-
-RDEPEND="
- $(python_gen_cond_dep '
- dev-python/contextlib2[${PYTHON_USEDEP}]
- dev-python/pathlib2[${PYTHON_USEDEP}]
- dev-python/singledispatch[${PYTHON_USEDEP}]
- dev-python/typing[${PYTHON_USEDEP}]
- ' -2)
- $(python_gen_cond_dep '
- dev-python/importlib_metadata[${PYTHON_USEDEP}]
- dev-python/zipp[${PYTHON_USEDEP}]
- ' pypy3 python3_{6,7})
-"
-BDEPEND="
- dev-python/toml[${PYTHON_USEDEP}]
- >=dev-python/setuptools_scm-3.4.1[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests unittest
-distutils_enable_sphinx docs dev-python/rst-linker dev-python/jaraco-packaging
-
-python_compile() {
- distutils-r1_python_compile
- if ! python_is_python3; then
- rm "${BUILD_DIR}/lib/importlib_resources/_py3.py" || die
- fi
-}
-
-python_install() {
- distutils-r1_python_install --skip-build
-}