summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-02-28 15:35:49 +0100
committerLouis Sautier <sbraz@gentoo.org>2020-02-28 16:37:00 +0100
commit0db1ac0e5a6e1900a2edb90f131a61b99d87b8d9 (patch)
treea0399a2715991a3d0429a65073dc9402aee96418 /dev-python/inflect
parentnet-analyzer/zabbix: bumps + security fixes + rewritten + removed obsolete (diff)
downloadgentoo-0db1ac0e5a6e1900a2edb90f131a61b99d87b8d9.tar.gz
gentoo-0db1ac0e5a6e1900a2edb90f131a61b99d87b8d9.tar.bz2
gentoo-0db1ac0e5a6e1900a2edb90f131a61b99d87b8d9.zip
dev-python/inflect: bump to 4.1.0
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/inflect')
-rw-r--r--dev-python/inflect/Manifest1
-rw-r--r--dev-python/inflect/inflect-4.1.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/inflect/Manifest b/dev-python/inflect/Manifest
index eba690cbdcea..c77e757b2007 100644
--- a/dev-python/inflect/Manifest
+++ b/dev-python/inflect/Manifest
@@ -1,3 +1,4 @@
DIST inflect-0.2.5.tar.gz 109756 BLAKE2B ecb64b0fea04602f112dfba11ade6828eae7a7f3f44d4c4fb15c2300ac18025ea4c51f9c36aae5e7e92bd09e24d08091ce096b888a520fd2d4c40374356333d5 SHA512 68371158ac90d9662c19657cbf697f44ee9ceac090286d53e29ee04252efbb7d0bfbd99ae6847e6eec1991ef4ef670eff60693d1f0a301885bab2a09c7ce4616
DIST inflect-3.0.2.tar.gz 71546 BLAKE2B 951eb818ba1645a9e426468811ad449378aa5a7341575ac2aff5e9d1e06237fe8e96fa64cd678665cd6c05e1dc5e477a65b261b9d8bd170be4fb923d5fb90e9c SHA512 5858548e947f742b91630fc584f568a2221057ada7cd4a55f39de1b52a82c97884d6a78c2f32e5995e354fd1c4eae4d5b3d30491ef57dd5187fd6baca93d2779
DIST inflect-4.0.0.tar.gz 71091 BLAKE2B 597db3d84cce1660ea92b84af5d07d77f537b2d738caedbe132ed9cb074a3c80c2f9e1cab321f0e231b2a29803f3b25206f27b78672c4917873007f3a56f1a8a SHA512 7d9ef9389b9301e596165fcb1774467ddeb421636094a0f0cebbcaa11558b4529ccb90644e1097f91cff3316911c98f4bb1df92180193a5313ca7da91a282e5c
+DIST inflect-4.1.0.tar.gz 72200 BLAKE2B c15f6b0d5d93050283dfc4d691e9fdbc26bb2f71573d6b397834e87af62f3afb8f5cdb0448c531de37e84729c0c6ae0cf4ea7a7b081a9dd784f7c06b962d7def SHA512 9a2ba4777f01475390976f3ac28f046d39d1f86cfdafd161cc7c8d33526aca35d44e6598ccf2a0b68d3511a64b67ed0991b51c78bda8f279cd706fd29a3fa514
diff --git a/dev-python/inflect/inflect-4.1.0.ebuild b/dev-python/inflect/inflect-4.1.0.ebuild
new file mode 100644
index 000000000000..6c7a9a01eb80
--- /dev/null
+++ b/dev-python/inflect/inflect-4.1.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6,7,8} )
+# [options.entry_points] is present in setup.cfg but it is empty
+DISTUTILS_USE_SETUPTOOLS=manual
+
+inherit distutils-r1
+
+DESCRIPTION="Correctly inflect words and numbers"
+HOMEPAGE="https://github.com/jazzband/inflect"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ $(python_gen_cond_dep 'dev-python/importlib_metadata[${PYTHON_USEDEP}]' pypy3 python3_{6,7})
+"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_sphinx docs '>=dev-python/jaraco-packaging-3.2' \
+ '>=dev-python/rst-linker-1.9' dev-python/alabaster
+
+python_test() {
+ # Override pytest options to skip flake8
+ pytest -vv tests --override-ini="addopts=--doctest-modules" \
+ || die "tests failed with ${EPYTHON}"
+}