summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-17 09:08:19 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-17 09:57:11 +0100
commitaca9e49fb889b0108ccc71bb5bd4dd39099ba91d (patch)
tree69d6dacb32ba6f4c6a0ec398e85796a97789c811 /dev-python/influxdb/influxdb-2.12.0.ebuild
parentdev-python/statsd: New package, ebuild written by me (diff)
downloadgentoo-aca9e49fb889b0108ccc71bb5bd4dd39099ba91d.tar.gz
gentoo-aca9e49fb889b0108ccc71bb5bd4dd39099ba91d.tar.bz2
gentoo-aca9e49fb889b0108ccc71bb5bd4dd39099ba91d.zip
dev-python/influxdb: New package, ebuild written by me
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/influxdb/influxdb-2.12.0.ebuild')
-rw-r--r--dev-python/influxdb/influxdb-2.12.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/influxdb/influxdb-2.12.0.ebuild b/dev-python/influxdb/influxdb-2.12.0.ebuild
new file mode 100644
index 000000000000..a5055d5f760d
--- /dev/null
+++ b/dev-python/influxdb/influxdb-2.12.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} )
+
+inherit distutils-r1
+
+DESCRIPTION="InfluxDB client"
+HOMEPAGE="https://github.com/influxdb/influxdb-python http://pypi.python.org/pypi/influxdb"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ >=dev-python/requests-1.0.3[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ nosetests --verbose || die
+}