summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2018-07-31 20:48:54 -0400
committerVirgil Dupras <vdupras@gentoo.org>2018-08-01 08:09:58 -0400
commitcfdccf48a2b1651a903f67bae2fc91dc132b9ed3 (patch)
tree96b95d6baea273ee3d7f7ae6c1cf51495f878efd /dev-python/invoke
parentdev-python/pytest-relaxed: disable plugin autoload (diff)
downloadgentoo-cfdccf48a2b1651a903f67bae2fc91dc132b9ed3.tar.gz
gentoo-cfdccf48a2b1651a903f67bae2fc91dc132b9ed3.tar.bz2
gentoo-cfdccf48a2b1651a903f67bae2fc91dc132b9ed3.zip
dev-python/invoke: explicitly load pytest-relaxed plugin
Bug: https://bugs.gentoo.org/661218 Package-Manager: Portage-2.3.44, Repoman-2.3.10
Diffstat (limited to 'dev-python/invoke')
-rw-r--r--dev-python/invoke/invoke-1.1.0.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/dev-python/invoke/invoke-1.1.0.ebuild b/dev-python/invoke/invoke-1.1.0.ebuild
index 80bbd00caf23..59e4a80b9830 100644
--- a/dev-python/invoke/invoke-1.1.0.ebuild
+++ b/dev-python/invoke/invoke-1.1.0.ebuild
@@ -29,5 +29,6 @@ PATCHES=(
python_test() {
# -s flag is important: tests fail when pytest isn't in "no capture" mode
- ${EPYTHON} -m pytest -s -v
+ # -p pytest_relaxed: this plugin has to be loaded explicitly
+ pytest -s -v -p pytest_relaxed.plugin || die "Tests failed"
}