summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2018-07-30 16:20:27 -0400
committerVirgil Dupras <vdupras@gentoo.org>2018-07-30 16:20:27 -0400
commitd10462334dd6722000f6f0c181430ac7d846a711 (patch)
tree7342759e7dc8cc2eedd668763b9c0806b99efcfd /dev-python/invoke
parentsys-boot/shim: 32 bit user != 32 bit system (diff)
downloadgentoo-d10462334dd6722000f6f0c181430ac7d846a711.tar.gz
gentoo-d10462334dd6722000f6f0c181430ac7d846a711.tar.bz2
gentoo-d10462334dd6722000f6f0c181430ac7d846a711.zip
dev-python/invoke: bump to 1.1.0
* EAPI 7 * Python 3.7 * Enable tests Package-Manager: Portage-2.3.44, Repoman-2.3.10
Diffstat (limited to 'dev-python/invoke')
-rw-r--r--dev-python/invoke/Manifest2
-rw-r--r--dev-python/invoke/files/invoke-1.1.0-skip-pty-tests.patch29
-rw-r--r--dev-python/invoke/invoke-0.22.1.ebuild15
-rw-r--r--dev-python/invoke/invoke-1.1.0.ebuild33
4 files changed, 63 insertions, 16 deletions
diff --git a/dev-python/invoke/Manifest b/dev-python/invoke/Manifest
index 401ff3b99819..3d33426132ae 100644
--- a/dev-python/invoke/Manifest
+++ b/dev-python/invoke/Manifest
@@ -1 +1 @@
-DIST invoke-0.22.1.tar.gz 292418 BLAKE2B ae392d3cd84ff58a0e2f24a8beed7b0d556a45d55a11fb5522bfe11351d2b47512e7910a18bad2db1e1475410d9c15b0af4cedbae06240133d5d8b320c362669 SHA512 e1c55435923bbfae8eb8f22a7dff81ce3e127cecbc0c33c002acb94d49c6cd41b7fbaf54beea654c77873bbbc8bcc85c7a61cf5789af80758d5b3abd7d2a61b0
+DIST invoke-1.1.0.tar.gz 309811 BLAKE2B d1832d141a50d5ee9039614191cc02f266f440fd939463d572218a79ded9384ac8dc71798f716482021a0cc39611bc51b73973b67973d3cd5a3d208608091e17 SHA512 6b8ebee7d2dd68fe0134491b15a3b85fd6d1493c5b81f00ba577c6bcf3e4a264d74f68bdd0d40a4c5bdde18c021395ee335d10dde8e676bc9efb313e1ae9b55c
diff --git a/dev-python/invoke/files/invoke-1.1.0-skip-pty-tests.patch b/dev-python/invoke/files/invoke-1.1.0-skip-pty-tests.patch
new file mode 100644
index 000000000000..d09eac74f91d
--- /dev/null
+++ b/dev-python/invoke/files/invoke-1.1.0-skip-pty-tests.patch
@@ -0,0 +1,29 @@
+This patch skips all tests related to PTYs: they all fail under portage
+because we don't have a valid TTY. Skip them. A bing chunk of them are
+skipped through "skipper()" under mock_pty. The rest of them are skipped
+by simulation windows (tests that don't run under windows don't run under
+portage either).
+diff --git a/tests/_util.py b/tests/_util.py
+index d954946b..27381cfd 100644
+--- a/tests/_util.py
++++ b/tests/_util.py
+@@ -24,7 +24,7 @@ support = os.path.join(os.path.dirname(__file__), "_support")
+ def skip_if_windows(fn):
+ @wraps(fn)
+ def wrapper(*args, **kwargs):
+- if WINDOWS:
++ if True:
+ skip()
+ return fn(*args, **kwargs)
+
+@@ -190,6 +190,10 @@ def mock_pty(
+ return skip_if_windows
+
+ def decorator(f):
++ def skipper(*args, **kwargs):
++ skip()
++
++ return skipper
+ import fcntl
+
+ ioctl_patch = patch("invoke.runners.fcntl.ioctl", wraps=fcntl.ioctl)
diff --git a/dev-python/invoke/invoke-0.22.1.ebuild b/dev-python/invoke/invoke-0.22.1.ebuild
deleted file mode 100644
index 1db8ec13df92..000000000000
--- a/dev-python/invoke/invoke-0.22.1.ebuild
+++ /dev/null
@@ -1,15 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
-inherit distutils-r1
-
-DESCRIPTION="Pythonic task execution"
-HOMEPAGE="https://pypi.org/project/invoke/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND=""
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
diff --git a/dev-python/invoke/invoke-1.1.0.ebuild b/dev-python/invoke/invoke-1.1.0.ebuild
new file mode 100644
index 000000000000..80bbd00caf23
--- /dev/null
+++ b/dev-python/invoke/invoke-1.1.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+inherit distutils-r1
+
+DESCRIPTION="Pythonic task execution"
+HOMEPAGE="https://pypi.org/project/invoke/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock
+ >=dev-python/pytest-3.0
+ dev-python/pytest-relaxed
+ )"
+RDEPEND=""
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.1.0-skip-pty-tests.patch"
+)
+
+python_test() {
+ # -s flag is important: tests fail when pytest isn't in "no capture" mode
+ ${EPYTHON} -m pytest -s -v
+}