summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-10-30 17:34:49 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-10-30 18:36:43 -0700
commit0b69939e88f6a0c80a0066773e7c30d9bbe33562 (patch)
tree88a19736e237324ed29c15e1fa0c244acd941525 /dev-python/ioflo/ioflo-2.0.2.ebuild
parentdev-python/cheetah3-3.2.6: Version bump, add py39 (diff)
downloadgentoo-0b69939e88f6a0c80a0066773e7c30d9bbe33562.tar.gz
gentoo-0b69939e88f6a0c80a0066773e7c30d9bbe33562.tar.bz2
gentoo-0b69939e88f6a0c80a0066773e7c30d9bbe33562.zip
dev-python/ioflo-2.0.2: Version bump, add py39
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/ioflo/ioflo-2.0.2.ebuild')
-rw-r--r--dev-python/ioflo/ioflo-2.0.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/ioflo/ioflo-2.0.2.ebuild b/dev-python/ioflo/ioflo-2.0.2.ebuild
new file mode 100644
index 000000000000..ee37a8b9765a
--- /dev/null
+++ b/dev-python/ioflo/ioflo-2.0.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=(python3_{7..9})
+inherit distutils-r1
+
+DESCRIPTION="Automated Reasoning Engine and Flow Based Programming Framework"
+HOMEPAGE="https://github.com/ioflo/ioflo/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ $(python_gen_cond_dep '>=dev-lang/python-3.7.4' python3_7)
+"
+BDEPEND="${RDEPEND}
+ test? (
+ dev-python/pytest-salt-factories[${PYTHON_USEDEP}]
+ app-admin/salt[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/ioflo-1.7.8-network-test.patch"
+)
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -e 's:"setuptools_git[^"]*",::' -i setup.py || die
+ distutils-r1_python_prepare_all
+}