summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-25 10:57:29 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-25 12:19:21 +0200
commitbb6eeec99e67a1875d7918e3a913808f7c0bc968 (patch)
tree0c947d562146b584fcf5d18731896312dacd1982 /dev-python/ipaddr/ipaddr-2.2.0-r1.ebuild
parentdev-python/namespace-google: Remove py2.7 (diff)
downloadgentoo-bb6eeec99e67a1875d7918e3a913808f7c0bc968.tar.gz
gentoo-bb6eeec99e67a1875d7918e3a913808f7c0bc968.tar.bz2
gentoo-bb6eeec99e67a1875d7918e3a913808f7c0bc968.zip
dev-python/ipaddr: Remove py2.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ipaddr/ipaddr-2.2.0-r1.ebuild')
-rw-r--r--dev-python/ipaddr/ipaddr-2.2.0-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/ipaddr/ipaddr-2.2.0-r1.ebuild b/dev-python/ipaddr/ipaddr-2.2.0-r1.ebuild
new file mode 100644
index 000000000000..4bc2aa1929eb
--- /dev/null
+++ b/dev-python/ipaddr/ipaddr-2.2.0-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python IP address manipulation library"
+HOMEPAGE="https://github.com/google/ipaddr-py https://pypi.org/project/ipaddr/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ~ppc64 x86"
+
+python_prepare() {
+ if python_is_python3; then
+ 2to3 -n -w --no-diffs *.py || die
+ fi
+}
+
+python_test() {
+ distutils_install_for_testing
+ "${EPYTHON}" ipaddr_test.py || die "Tests fail with ${EPYTHON}"
+}