summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2015-11-27 16:21:28 +0100
committerMarius Brehler <marbre@linux.sungazer.de>2015-11-27 16:21:28 +0100
commitbfc70843b1ca7935cc7dc43746b5682bf719e74a (patch)
treede48c7ea7a2eb17c83377f6eaa802b070c18392c /dev-python/ipyparallel/ipyparallel-4.1.0.ebuild
parentdev-python/jupyter_client: Import from science overlay (diff)
downloadgentoo-bfc70843b1ca7935cc7dc43746b5682bf719e74a.tar.gz
gentoo-bfc70843b1ca7935cc7dc43746b5682bf719e74a.tar.bz2
gentoo-bfc70843b1ca7935cc7dc43746b5682bf719e74a.zip
dev-python/ipyparallel: Import from science overlay
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-python/ipyparallel/ipyparallel-4.1.0.ebuild')
-rw-r--r--dev-python/ipyparallel/ipyparallel-4.1.0.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/ipyparallel/ipyparallel-4.1.0.ebuild b/dev-python/ipyparallel/ipyparallel-4.1.0.ebuild
new file mode 100644
index 000000000000..be83c50bd057
--- /dev/null
+++ b/dev-python/ipyparallel/ipyparallel-4.1.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Interactive Parallel Computing with IPython"
+HOMEPAGE="http://ipython.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/ipython_genutils[${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-14.4.0[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ !<dev-python/ipython-4.0.0[smp]
+ >=dev-python/ipython-4.0.0[${PYTHON_USEDEP}]
+ dev-python/jupyter_client[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ )
+ "
+
+python_prepare_all() {
+ # Prevent un-needed download during build
+ if use doc; then
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/source/conf.py || die
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ iptest --coverage xml ipyparallel.tests || die
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( docs/build/html/. )
+ distutils-r1_python_install_all
+}