summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-08-19 22:33:37 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-08-19 22:33:37 +0000
commited80f857532c9ab3650c6aca6c03507d487d38e0 (patch)
tree27b6491786e3c8321fb6b4e019721894b6fca7d5 /dev-python/ipyparallel
parentdev-python/ipykernel: add conditional block on ipython-6 for python-2.7 (diff)
downloadgentoo-ed80f857532c9ab3650c6aca6c03507d487d38e0.tar.gz
gentoo-ed80f857532c9ab3650c6aca6c03507d487d38e0.tar.bz2
gentoo-ed80f857532c9ab3650c6aca6c03507d487d38e0.zip
dev-python/ipyparallel: add conditional block on ipython-6 for python-2.7
Package-Manager: Portage-2.3.7, Repoman-2.3.3
Diffstat (limited to 'dev-python/ipyparallel')
-rw-r--r--dev-python/ipyparallel/ipyparallel-4.1.0.ebuild3
-rw-r--r--dev-python/ipyparallel/ipyparallel-5.0.1.ebuild3
-rw-r--r--dev-python/ipyparallel/ipyparallel-5.1.1.ebuild3
-rw-r--r--dev-python/ipyparallel/ipyparallel-5.2.0.ebuild3
-rw-r--r--dev-python/ipyparallel/ipyparallel-6.0.2-r1.ebuild63
-rw-r--r--dev-python/ipyparallel/ipyparallel-6.0.2.ebuild1
-rw-r--r--dev-python/ipyparallel/metadata.xml2
7 files changed, 73 insertions, 5 deletions
diff --git a/dev-python/ipyparallel/ipyparallel-4.1.0.ebuild b/dev-python/ipyparallel/ipyparallel-4.1.0.ebuild
index 94b1c39303fc..62d09048ca07 100644
--- a/dev-python/ipyparallel/ipyparallel-4.1.0.ebuild
+++ b/dev-python/ipyparallel/ipyparallel-4.1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -24,6 +24,7 @@ RDEPEND="
dev-python/ipykernel[${PYTHON_USEDEP}]
!<dev-python/ipython-4.0.0[smp]
>=dev-python/ipython-4.0.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '<dev-python/ipython-6[${PYTHON_USEDEP}]' 'python2_7')
dev-python/jupyter_client[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
diff --git a/dev-python/ipyparallel/ipyparallel-5.0.1.ebuild b/dev-python/ipyparallel/ipyparallel-5.0.1.ebuild
index 3703b40eb6e4..d7477fdddfac 100644
--- a/dev-python/ipyparallel/ipyparallel-5.0.1.ebuild
+++ b/dev-python/ipyparallel/ipyparallel-5.0.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -24,6 +24,7 @@ RDEPEND="
dev-python/ipykernel[${PYTHON_USEDEP}]
!<dev-python/ipython-4.0.0[smp]
>=dev-python/ipython-4.0.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '<dev-python/ipython-6[${PYTHON_USEDEP}]' 'python2_7')
dev-python/jupyter_client[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
diff --git a/dev-python/ipyparallel/ipyparallel-5.1.1.ebuild b/dev-python/ipyparallel/ipyparallel-5.1.1.ebuild
index 6012661d73f3..459d8e5dc1b1 100644
--- a/dev-python/ipyparallel/ipyparallel-5.1.1.ebuild
+++ b/dev-python/ipyparallel/ipyparallel-5.1.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -24,6 +24,7 @@ RDEPEND="
dev-python/ipykernel[${PYTHON_USEDEP}]
!<dev-python/ipython-4.0.0[smp]
>=dev-python/ipython-4.0.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '<dev-python/ipython-6[${PYTHON_USEDEP}]' 'python2_7')
dev-python/notebook[${PYTHON_USEDEP}]
dev-python/jupyter_client[${PYTHON_USEDEP}]
www-servers/tornado[${PYTHON_USEDEP}]
diff --git a/dev-python/ipyparallel/ipyparallel-5.2.0.ebuild b/dev-python/ipyparallel/ipyparallel-5.2.0.ebuild
index 5dd5e10510cc..41ea11d938aa 100644
--- a/dev-python/ipyparallel/ipyparallel-5.2.0.ebuild
+++ b/dev-python/ipyparallel/ipyparallel-5.2.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -24,6 +24,7 @@ RDEPEND="
dev-python/ipykernel[${PYTHON_USEDEP}]
!<dev-python/ipython-4.0.0[smp]
>=dev-python/ipython-4.0.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '<dev-python/ipython-6[${PYTHON_USEDEP}]' 'python2_7')
dev-python/notebook[${PYTHON_USEDEP}]
dev-python/jupyter_client[${PYTHON_USEDEP}]
www-servers/tornado[${PYTHON_USEDEP}]
diff --git a/dev-python/ipyparallel/ipyparallel-6.0.2-r1.ebuild b/dev-python/ipyparallel/ipyparallel-6.0.2-r1.ebuild
new file mode 100644
index 000000000000..5b18b53468df
--- /dev/null
+++ b/dev-python/ipyparallel/ipyparallel-6.0.2-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Interactive Parallel Computing with IPython"
+HOMEPAGE="https://ipyparallel.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ !<dev-python/ipython-4.0.0[smp,${PYTHON_USEDEP}]
+ >=dev-python/ipython-4.0.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '<dev-python/ipython-6[${PYTHON_USEDEP}]' 'python2_7')
+ dev-python/ipython_genutils[${PYTHON_USEDEP}]
+ dev-python/jupyter_client[${PYTHON_USEDEP}]
+ dev-python/notebook[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-14.4.0[${PYTHON_USEDEP}]
+ www-servers/tornado[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ virtual/python-futures[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-18.5[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/testpath[${PYTHON_USEDEP}]
+ )
+ "
+
+python_prepare_all() {
+ # Prevent un-needed download during build
+ if use doc; then
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/source/conf.py || die
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ emake -C docs html
+ HTML_DOCS=( docs/build/html/. )
+ fi
+}
+
+python_test() {
+ iptest --coverage xml ipyparallel.tests -- -vsx || die
+}
diff --git a/dev-python/ipyparallel/ipyparallel-6.0.2.ebuild b/dev-python/ipyparallel/ipyparallel-6.0.2.ebuild
index 3f686896a645..646d41f54228 100644
--- a/dev-python/ipyparallel/ipyparallel-6.0.2.ebuild
+++ b/dev-python/ipyparallel/ipyparallel-6.0.2.ebuild
@@ -25,6 +25,7 @@ RDEPEND="
dev-python/ipykernel[${PYTHON_USEDEP}]
!<dev-python/ipython-4.0.0[smp]
>=dev-python/ipython-4.0.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '<dev-python/ipython-6[${PYTHON_USEDEP}]' 'python2_7')
dev-python/notebook[${PYTHON_USEDEP}]
dev-python/jupyter_client[${PYTHON_USEDEP}]
www-servers/tornado[${PYTHON_USEDEP}]
diff --git a/dev-python/ipyparallel/metadata.xml b/dev-python/ipyparallel/metadata.xml
index f58431f0f4bc..742b296901f6 100644
--- a/dev-python/ipyparallel/metadata.xml
+++ b/dev-python/ipyparallel/metadata.xml
@@ -6,7 +6,7 @@
<name>Gentoo Science Project</name>
</maintainer>
<longdescription>
- Interactive Parallel Computing with IPython.
+ Interactive Parallel Computing with IPython.
ipyparallel is the new home of IPython.parallel.
</longdescription>
<upstream>