summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-16 10:05:51 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-16 10:10:27 +0100
commit131cbe59ac0bca7645ea0616272a38a51a34ffe0 (patch)
tree40333d4161f2252189720feeb648b46ed1a33751 /dev-python/ipywidgets
parentdev-python/widgetsnbextension: Bump to 3.6.0 (diff)
downloadgentoo-131cbe59ac0bca7645ea0616272a38a51a34ffe0.tar.gz
gentoo-131cbe59ac0bca7645ea0616272a38a51a34ffe0.tar.bz2
gentoo-131cbe59ac0bca7645ea0616272a38a51a34ffe0.zip
dev-python/ipywidgets: Bump to 7.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ipywidgets')
-rw-r--r--dev-python/ipywidgets/Manifest1
-rw-r--r--dev-python/ipywidgets/ipywidgets-7.7.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/ipywidgets/Manifest b/dev-python/ipywidgets/Manifest
index 21ad33d8658f..3cce861b413e 100644
--- a/dev-python/ipywidgets/Manifest
+++ b/dev-python/ipywidgets/Manifest
@@ -1 +1,2 @@
DIST ipywidgets-7.6.5.tar.gz 4072535 BLAKE2B bc2347863af42254e740454e1d91ca8b7fc03de9dc6a2fdddaf9dbb13da2fe7af0f429733166865ebcdda9840189fc65dc677b7181b34f1c0dc697905aa3af4f SHA512 4952f1cd293f1a4bf1721222579273c95f59adfa9385963617924f5f28232e1940ec045e18aeae83ad138176e4d887e952fe875b960279f3e0b7d982a790a4dc
+DIST ipywidgets-7.7.0.tar.gz 4074763 BLAKE2B cff338dd635c57943161c78708e6a69abccaa46878e0bedb11ead76590b858ba57ce4dcfa8052533a4849da0dc9d5472987a7918fd2043462a21a908105d7910 SHA512 038da040912e6701762fb66fb3b6996ce0a59706afb05405b5932c02d34733842b227426f0b29eea115196bab384617425b0553c5db13a9dc832bddef63dfb92
diff --git a/dev-python/ipywidgets/ipywidgets-7.7.0.ebuild b/dev-python/ipywidgets/ipywidgets-7.7.0.ebuild
new file mode 100644
index 000000000000..53ac748a0cc1
--- /dev/null
+++ b/dev-python/ipywidgets/ipywidgets-7.7.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="IPython HTML widgets for Jupyter"
+HOMEPAGE="https://ipywidgets.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/ipykernel-4.5.1[${PYTHON_USEDEP}]
+ >=dev-python/ipython_genutils-0.2.0[${PYTHON_USEDEP}]
+ >=dev-python/nbformat-4.2.0[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-4.3.1[${PYTHON_USEDEP}]
+ >=dev-python/widgetsnbextension-3.6.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # upstream hack to autoconfigure ipywidgets in jupyter
+ # we don't have jupyterlab_widgets packaged
+ sed -i -e '/jupyterlab_widgets/d' setup.py || die
+ distutils-r1_src_prepare
+}