summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-25 09:27:05 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-25 09:37:43 +0100
commit3516d5ba53c73289b977a581657294c19e7fc2d3 (patch)
tree332271ce54235c3e3553bc2bd2673570dffc9a1e /dev-python/ipywidgets
parentdev-python/pytz: Bump to 2020.5 (diff)
downloadgentoo-3516d5ba53c73289b977a581657294c19e7fc2d3.tar.gz
gentoo-3516d5ba53c73289b977a581657294c19e7fc2d3.tar.bz2
gentoo-3516d5ba53c73289b977a581657294c19e7fc2d3.zip
dev-python/ipywidgets: Bump to 7.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ipywidgets')
-rw-r--r--dev-python/ipywidgets/Manifest1
-rw-r--r--dev-python/ipywidgets/ipywidgets-7.6.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/ipywidgets/Manifest b/dev-python/ipywidgets/Manifest
index a50dd9207c01..deb0abea9c2f 100644
--- a/dev-python/ipywidgets/Manifest
+++ b/dev-python/ipywidgets/Manifest
@@ -1 +1,2 @@
DIST ipywidgets-7.5.1.tar.gz 5656334 BLAKE2B 8bd98f523b619bea02e01ae5faffb08040dc5011905dd69510728b02736e66444b3c3cdf1e7272884c1df97f610aff790063f783e1d0939786669ef39cd1fc94 SHA512 856b3e4dad331766eff6e5f1fd31984a4b6ede5c678ffd51a4896f6448dac53ba181ccec2821f10e07e0f1095318427affe19f1420d0337bc3d37ef1e0a9ea0d
+DIST ipywidgets-7.6.0.tar.gz 4066107 BLAKE2B 5e5f9f6fca1e554ef2b6157a493435148a9832c7f69ec1245e24828363e2a9a1edea804236beaff1f0870d3c7aa028d329e18bc7b1aade7b212110dda3be018a SHA512 eee04406d90f8cadab0208923d51679677b6f630417b69acd0382fcb69cf3d727e47e5abde071939f0b5f45b8b0e72d0bf9316e41508c2c0df7518bfb322db51
diff --git a/dev-python/ipywidgets/ipywidgets-7.6.0.ebuild b/dev-python/ipywidgets/ipywidgets-7.6.0.ebuild
new file mode 100644
index 000000000000..feaa1edb8dc0
--- /dev/null
+++ b/dev-python/ipywidgets/ipywidgets-7.6.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="IPython HTML widgets for Jupyter"
+HOMEPAGE="https://ipywidgets.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/ipykernel-4.5.1[${PYTHON_USEDEP}]
+ >=dev-python/nbformat-4.2.0[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-4.3.1[${PYTHON_USEDEP}]
+ >=dev-python/widgetsnbextension-3.5.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest