summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-29 16:00:38 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-29 16:01:22 +0100
commit6590907098f83b85ff97b3b8921b5a90e3d9d3a8 (patch)
treee5b15acee63367d61d545e8297d7f1ff87481a6c /dev-python/ipywidgets
parentdev-python/ipython_genutils: Switch to PEP 517 build (diff)
downloadgentoo-6590907098f83b85ff97b3b8921b5a90e3d9d3a8.tar.gz
gentoo-6590907098f83b85ff97b3b8921b5a90e3d9d3a8.tar.bz2
gentoo-6590907098f83b85ff97b3b8921b5a90e3d9d3a8.zip
dev-python/ipywidgets: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ipywidgets')
-rw-r--r--dev-python/ipywidgets/ipywidgets-7.6.5-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/ipywidgets/ipywidgets-7.6.5-r1.ebuild b/dev-python/ipywidgets/ipywidgets-7.6.5-r1.ebuild
new file mode 100644
index 000000000000..d5960928a26b
--- /dev/null
+++ b/dev-python/ipywidgets/ipywidgets-7.6.5-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="IPython HTML widgets for Jupyter"
+HOMEPAGE="https://ipywidgets.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/ipykernel-4.5.1[${PYTHON_USEDEP}]
+ >=dev-python/ipython_genutils-0.2.0[${PYTHON_USEDEP}]
+ >=dev-python/nbformat-4.2.0[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-4.3.1[${PYTHON_USEDEP}]
+ >=dev-python/widgetsnbextension-3.5.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}/${PN}-7.6.3-py310.patch"
+)