summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-02 10:39:45 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-02 11:11:52 +0200
commit8ee75e813f1a98130f56b5f49ff612ac14ffe02e (patch)
treea1e28481712f50a683572d21d3a2ec6c19693e5b /dev-python/ipywidgets
parentdev-python/octave_kernel: Remove py3.6 due to ipython (diff)
downloadgentoo-8ee75e813f1a98130f56b5f49ff612ac14ffe02e.tar.gz
gentoo-8ee75e813f1a98130f56b5f49ff612ac14ffe02e.tar.bz2
gentoo-8ee75e813f1a98130f56b5f49ff612ac14ffe02e.zip
dev-python/ipywidgets: Remove py3.6 in new rev due to ipython
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ipywidgets')
-rw-r--r--dev-python/ipywidgets/ipywidgets-7.5.1-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/ipywidgets/ipywidgets-7.5.1-r1.ebuild b/dev-python/ipywidgets/ipywidgets-7.5.1-r1.ebuild
new file mode 100644
index 000000000000..feaa1edb8dc0
--- /dev/null
+++ b/dev-python/ipywidgets/ipywidgets-7.5.1-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="IPython HTML widgets for Jupyter"
+HOMEPAGE="https://ipywidgets.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/ipykernel-4.5.1[${PYTHON_USEDEP}]
+ >=dev-python/nbformat-4.2.0[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-4.3.1[${PYTHON_USEDEP}]
+ >=dev-python/widgetsnbextension-3.5.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest