summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-08 08:43:22 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-08 10:51:58 +0200
commit0db37d0caa6a9a6bad671436cab141476449341c (patch)
treef208efdbefaba9f5bc1597d3118ab20df889023a /dev-python/irc
parentdev-python/jaraco-logging: Enable python3.10 (diff)
downloadgentoo-0db37d0caa6a9a6bad671436cab141476449341c.tar.gz
gentoo-0db37d0caa6a9a6bad671436cab141476449341c.tar.bz2
gentoo-0db37d0caa6a9a6bad671436cab141476449341c.zip
dev-python/irc: Enable python3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/irc')
-rw-r--r--dev-python/irc/irc-19.0.1.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/dev-python/irc/irc-19.0.1.ebuild b/dev-python/irc/irc-19.0.1.ebuild
index 1fab5e299ca2..195c778ba272 100644
--- a/dev-python/irc/irc-19.0.1.ebuild
+++ b/dev-python/irc/irc-19.0.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{7..10} )
inherit distutils-r1
@@ -43,8 +43,7 @@ distutils_enable_sphinx docs '>=dev-python/jaraco-packaging-3.2' \
python_test() {
# Override pytest options to skip flake8
- pytest -vv --override-ini="addopts=--doctest-modules" \
- || die "Tests failed with ${EPYTHON}"
+ epytest --override-ini="addopts=--doctest-modules"
}
python_install_all() {