summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-12 18:42:38 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-12 18:52:51 +0200
commit6133c62e8102eb0bb14202966bff16be399226ee (patch)
tree7cb52b1f07e2bacc29cb8093df0b0f2018bffa61 /dev-python/irc
parentdev-python/ipywidgets: Remove redundant versions (diff)
downloadgentoo-6133c62e8102eb0bb14202966bff16be399226ee.tar.gz
gentoo-6133c62e8102eb0bb14202966bff16be399226ee.tar.bz2
gentoo-6133c62e8102eb0bb14202966bff16be399226ee.zip
dev-python/irc: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/irc')
-rw-r--r--dev-python/irc/Manifest1
-rw-r--r--dev-python/irc/irc-16.3.ebuild66
2 files changed, 0 insertions, 67 deletions
diff --git a/dev-python/irc/Manifest b/dev-python/irc/Manifest
index 8fc3c9f09bb6..55803bbf7c32 100644
--- a/dev-python/irc/Manifest
+++ b/dev-python/irc/Manifest
@@ -1,2 +1 @@
-DIST irc-16.3.tar.gz 87067 BLAKE2B 61d8b9cc20390a3eb918e5593a167b28f37154ee05cb4d7a72f8901509d3345e8d6bee9c17b66aa6c71fad4608a9f98eb3848190f82eac7db6f2013227979c25 SHA512 84b5a56a441cdf22396c10b81c115cb2e297ac082785e9baf0bc73d655034be1ff3f553d44412f066ab4b74530faddb66a9cc2f511a332e87fe49af0b6e68e5b
DIST irc-18.0.0.tar.gz 91529 BLAKE2B 91e7f9fe38b46f836eb902c8ce4ca04706e673a8a9372c743e9b6be3b400e4d84a0d841b72e2b8444e055a69d37b22d48fcf33c7bd51375dbf0dd4a06b3ed5dd SHA512 a424f1261a09246dd2cfd0b717d4fd9bbeab9754d1f480c870c2e131354db85268bd010ec6b7cf2c59a0c32057bb290ef3ffdcb30cca8c0d833e1497bc89f58e
diff --git a/dev-python/irc/irc-16.3.ebuild b/dev-python/irc/irc-16.3.ebuild
deleted file mode 100644
index f917dce5e7c4..000000000000
--- a/dev-python/irc/irc-16.3.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="IRC client framework written in Python"
-HOMEPAGE="https://github.com/jaraco/irc"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/jaraco-functools-1.5[${PYTHON_USEDEP}]
- >=dev-python/jaraco-itertools-1.8[${PYTHON_USEDEP}]
- >=dev-python/tempora-1.6[${PYTHON_USEDEP}]
- dev-python/jaraco-collections[${PYTHON_USEDEP}]
- dev-python/jaraco-logging[${PYTHON_USEDEP}]
- dev-python/jaraco-stream[${PYTHON_USEDEP}]
- dev-python/jaraco-text[${PYTHON_USEDEP}]
- dev-python/more-itertools[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
- doc? (
- >=dev-python/jaraco-packaging-3.2[${PYTHON_USEDEP}]
- >=dev-python/rst-linker-1.9[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- )
- test? (
- ${RDEPEND}
- dev-python/backports-unittest-mock[${PYTHON_USEDEP}]
- >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
- )
-"
-
-python_compile_all() {
- if use doc; then
- cd docs || die
- sphinx-build . _build/html || die
- HTML_DOCS=( docs/_build/html/. )
- fi
-}
-
-python_test() {
- # Override pytest options to skip flake8
- pytest -vv --override-ini="addopts=--doctest-modules" \
- || die "Tests failed with ${EPYTHON}"
-}
-
-python_install_all() {
- if use examples; then
- docompress -x "/usr/share/doc/${PF}/scripts"
- dodoc -r scripts
- fi
- distutils-r1_python_install_all
-}