summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-08-25 13:18:04 +0200
committerJustin Lecher <jlec@gentoo.org>2015-08-25 13:18:33 +0200
commit61d877aaff6533bbbc59c1469d56836d2458941f (patch)
treefda1e1af5b698eecaa80e62f5b0cdd411cb18b86 /dev-python/isodate/isodate-0.5.4.ebuild
parentdev-python/pytest-runner: Version Bump (diff)
downloadgentoo-61d877aaff6533bbbc59c1469d56836d2458941f.tar.gz
gentoo-61d877aaff6533bbbc59c1469d56836d2458941f.tar.bz2
gentoo-61d877aaff6533bbbc59c1469d56836d2458941f.zip
dev-python/isodate: Version Bump
Package-Manager: portage-2.2.20.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/isodate/isodate-0.5.4.ebuild')
-rw-r--r--dev-python/isodate/isodate-0.5.4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/isodate/isodate-0.5.4.ebuild b/dev-python/isodate/isodate-0.5.4.ebuild
new file mode 100644
index 000000000000..f8844cb18f7b
--- /dev/null
+++ b/dev-python/isodate/isodate-0.5.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="ISO 8601 date/time/duration parser and formater"
+HOMEPAGE="https://pypi.python.org/pypi/isodate"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ local test
+ pushd "${BUILD_DIR}"/lib/
+ for test in ${PN}/tests/test_*.py
+ do
+ if ! "${PYTHON}" $test; then
+ die "Test $test failed under ${EPYTHON}"
+ fi
+ done
+ # Give some order to the output salad
+ einfo "Testsuite passed under ${EPYTHON}";einfo ""
+}