summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/isodate
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/isodate')
-rw-r--r--dev-python/isodate/Manifest2
-rw-r--r--dev-python/isodate/isodate-0.5.0.ebuild33
-rw-r--r--dev-python/isodate/isodate-0.5.1.ebuild33
-rw-r--r--dev-python/isodate/metadata.xml21
4 files changed, 89 insertions, 0 deletions
diff --git a/dev-python/isodate/Manifest b/dev-python/isodate/Manifest
new file mode 100644
index 000000000000..8531ce1a22dc
--- /dev/null
+++ b/dev-python/isodate/Manifest
@@ -0,0 +1,2 @@
+DIST isodate-0.5.0.tar.gz 25917 SHA256 f3e436a9c321882942a6c62e9d8ea49787b4c0ea7f7bb3cbd047bcf76bd0dfbe SHA512 5f45fee798e8f79a5f9f271570d542fb68936577e3670a675e66e037bb15d76653717d7fcdeae1cd6ae9afb2f153206210c40d4cfcd8bd60c3ed873d2e6b19d4 WHIRLPOOL a9a62054c5b050a20240699a0955cf1a59f7c9afb4b163f0ef16b6fce578263881e3c8d77dc15a3ac1d11a341f64073685aa8a1d533391884d2d5f956f76a1a0
+DIST isodate-0.5.1.tar.gz 26859 SHA256 b12aed31c0e834543497e24d609a41531a800d8304c39e6665c45ca023b012fb SHA512 8bc1006a1d3aa03fc69885415f2acc18efde870d1c8e5ac9741672b2818983fabb781d853766105298fc55d187add20f4e3a4bf33966fc5b9d5f5ca08dc77748 WHIRLPOOL b246e35c93bf8001b7b7519c811cf7bda3cf669ace008e8f7ba4ee26e88b764468d326c9c145709a626a11e8358368dda2440a0fcf60587d22dbd6bce8825655
diff --git a/dev-python/isodate/isodate-0.5.0.ebuild b/dev-python/isodate/isodate-0.5.0.ebuild
new file mode 100644
index 000000000000..cb9722cb8900
--- /dev/null
+++ b/dev-python/isodate/isodate-0.5.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="ISO 8601 date/time/duration parser and formater"
+HOMEPAGE="http://pypi.python.org/pypi/isodate"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ local test
+ pushd "${BUILD_DIR}"/lib/
+ for test in ${PN}/tests/test_*.py
+ do
+ if ! "${PYTHON}" $test; then
+ die "Test $test failed under ${EPYTHON}"
+ fi
+ done
+ # Give some order to the output salad
+ einfo "Testsuite passed under ${EPYTHON}";einfo ""
+}
diff --git a/dev-python/isodate/isodate-0.5.1.ebuild b/dev-python/isodate/isodate-0.5.1.ebuild
new file mode 100644
index 000000000000..cb9722cb8900
--- /dev/null
+++ b/dev-python/isodate/isodate-0.5.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="ISO 8601 date/time/duration parser and formater"
+HOMEPAGE="http://pypi.python.org/pypi/isodate"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ local test
+ pushd "${BUILD_DIR}"/lib/
+ for test in ${PN}/tests/test_*.py
+ do
+ if ! "${PYTHON}" $test; then
+ die "Test $test failed under ${EPYTHON}"
+ fi
+ done
+ # Give some order to the output salad
+ einfo "Testsuite passed under ${EPYTHON}";einfo ""
+}
diff --git a/dev-python/isodate/metadata.xml b/dev-python/isodate/metadata.xml
new file mode 100644
index 000000000000..1a5711f648c5
--- /dev/null
+++ b/dev-python/isodate/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <longdescription>
+ This module implements ISO 8601 date, time and duration
+ parsing. The implementation follows ISO8601:2004 standard, and
+ implements only date/time representations mentioned in the standard. If
+ something is not mentioned there, then it is treated as non existent,
+ and not as an allowed option.
+ As this module maps ISO 8601 dates/times to standard Python data types,
+ like date, time, datetime and timedelta, it is not possible to convert
+ all possible ISO 8601 dates/times. For instance, dates before 0001-01-01
+ are not allowed by the Python date and datetime classes. Additionally
+ fractional seconds are limited to microseconds. That means if the parser
+ finds for instance nanoseconds it will round it to microseconds.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">isodate</remote-id>
+ </upstream>
+</pkgmetadata>