summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-15 15:09:22 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-15 15:09:22 +0100
commit4d5ae9affc17184d11f4e95699b7720e74a0d331 (patch)
treeb7d0431c061c5b70f03c9bf1291b96c1f9c20254 /dev-python/isort
parentdev-python/jaraco-itertools: Remove old (diff)
downloadgentoo-4d5ae9affc17184d11f4e95699b7720e74a0d331.tar.gz
gentoo-4d5ae9affc17184d11f4e95699b7720e74a0d331.tar.bz2
gentoo-4d5ae9affc17184d11f4e95699b7720e74a0d331.zip
dev-python/isort: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/isort')
-rw-r--r--dev-python/isort/isort-5.10.1.ebuild61
1 files changed, 0 insertions, 61 deletions
diff --git a/dev-python/isort/isort-5.10.1.ebuild b/dev-python/isort/isort-5.10.1.ebuild
deleted file mode 100644
index 6ccbdc080667..000000000000
--- a/dev-python/isort/isort-5.10.1.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_SETUPTOOLS=pyproject.toml
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="A python utility/library to sort imports"
-HOMEPAGE="https://pypi.org/project/isort/"
-SRC_URI="
- https://github.com/PyCQA/isort/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- dev-python/toml[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- dev-python/black[${PYTHON_USEDEP}]
- dev-python/colorama[${PYTHON_USEDEP}]
- dev-python/hypothesis[${PYTHON_USEDEP}]
- dev-python/natsort[${PYTHON_USEDEP}]
- dev-python/pylama[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-vcs/git
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # unbundle toml
- sed -i -e 's:from ._vendored ::' isort/settings.py || die
-
- distutils-r1_src_prepare
-}
-
-python_test() {
- # Some tests run the "isort" command
- distutils_install_for_testing
- # Install necessary plugins
- local p
- for p in example*/; do
- pushd "${p}" >/dev/null || die
- distutils_install_for_testing
- popd >/dev/null || die
- done
- # remove examples leaked into BUILD_DIR
- rm "${BUILD_DIR}"/lib/example* || die
-
- local EPYTEST_IGNORE=(
- # Excluded from upstream's test script
- tests/unit/test_deprecated_finders.py
- )
- epytest tests/unit
-}