summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-12-06 11:18:09 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-12-06 11:18:31 -0800
commit5e78d68ea903198a5b3a9bbe72d00c731e250231 (patch)
tree3b099bdb681d52ae62e1dc80085cc95fde2f920b /dev-python/isort
parentdev-python/pipfile: New package (diff)
downloadgentoo-5e78d68ea903198a5b3a9bbe72d00c731e250231.tar.gz
gentoo-5e78d68ea903198a5b3a9bbe72d00c731e250231.tar.bz2
gentoo-5e78d68ea903198a5b3a9bbe72d00c731e250231.zip
dev-python/isort-4.3.21_p2: Version bump, add py38, pypy3
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/isort')
-rw-r--r--dev-python/isort/Manifest1
-rw-r--r--dev-python/isort/files/isort-4.3.21_p1-tests.patch36
-rw-r--r--dev-python/isort/isort-4.3.21_p2.ebuild32
3 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/isort/Manifest b/dev-python/isort/Manifest
index 4df4bd97712f..80b4bd481b33 100644
--- a/dev-python/isort/Manifest
+++ b/dev-python/isort/Manifest
@@ -1,2 +1,3 @@
DIST isort-4.2.5.tar.gz 36361 BLAKE2B 7133ab999200412bc880a5413de81ff0b7718383eaf7f50dd1ca12da4d7ee24f8d47af60e7416ca6898a32074779c4f293d897a0f7d62c2539b10a686484c121 SHA512 ddc8e859bb421e4179315d74896958c8279394d42a75494db5dc22c58422994aa249b63c03645626a021ccf9142941bde51ad400256ab1c6be29da8110375f40
DIST isort-4.3.15.tar.gz 67949 BLAKE2B e78960518928cd74c15733bbc14bf066798ecbcc3e906754c10e352e7b88843451a1d0616d1b450100c77e95974f863951d640c9568277e867fcdfba8f44abdb SHA512 a5774d4f3c49c978e9043e52681e80011591422e60178d72074142725d9d7fa5065553686fd42bffe9e71b38b2b5bdaaa6f20e32cd8dbe33beb9431c397d78e5
+DIST isort-4.3.21_p2.tar.gz 158539 BLAKE2B 316703ca754c939e4af0db4a1060fb13a5164797a672b3faeb585a81fa0c86453fb0f1953b789661588cd0f04267a28837d46a88093a838391f752afa43e9f8b SHA512 fc2aa00c87196864864d2516b8be7acdedcf40d71d1931510e4b878dbd2b6da0b579661b50221f03f4aa5560c8bf23d5e1e10a2694d2b741ca09a92e40a4c687
diff --git a/dev-python/isort/files/isort-4.3.21_p1-tests.patch b/dev-python/isort/files/isort-4.3.21_p1-tests.patch
new file mode 100644
index 000000000000..9ece5ff6de9b
--- /dev/null
+++ b/dev-python/isort/files/isort-4.3.21_p1-tests.patch
@@ -0,0 +1,36 @@
+diff --git a/test_isort.py b/test_isort.py
+index 9d9297c..725b1e1 100644
+--- a/test_isort.py
++++ b/test_isort.py
+@@ -1539,6 +1539,7 @@ def test_custom_sections():
+ "import p24.shared.media_wiki_syntax as syntax\n")
+
+
++@pytest.mark.skip("Not going to pull in Django for a couple of tests")
+ def test_glob_known():
+ """Ensure that most specific placement control match wins"""
+ test_input = ("import os\n"
+@@ -2599,6 +2600,7 @@ def test_new_lines_are_preserved():
+ os.remove(n_newline.name)
+
+
++@pytest.mark.skip("Not going to pull in Django for a couple of tests")
+ def test_requirements_finder(tmpdir):
+ subdir = tmpdir.mkdir('subdir').join("lol.txt")
+ subdir.write("flask")
+@@ -2675,6 +2677,7 @@ deal = {editable = true, git = "https://github.com/orsinium/deal.git"}
+ """
+
+
++@pytest.mark.skip("Not going to pull in Django for a couple of tests")
+ def test_pipfile_finder(tmpdir):
+ pipfile = tmpdir.join('Pipfile')
+ pipfile.write(PIPFILE)
+@@ -2979,6 +2982,7 @@ def test_skip_paths_issue_938(tmpdir):
+ assert b'skipped 1' in results.lower()
+
+
++@pytest.mark.skipif(sys.version_info[0] == 2, reason="Broken on Python 2")
+ def test_standard_library_deprecates_user_issue_778():
+ test_input = ('import os\n'
+ '\n'
diff --git a/dev-python/isort/isort-4.3.21_p2.ebuild b/dev-python/isort/isort-4.3.21_p2.ebuild
new file mode 100644
index 000000000000..c55537150d53
--- /dev/null
+++ b/dev-python/isort/isort-4.3.21_p2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
+
+inherit distutils-r1
+
+MY_PV="${PV//_p/-}"
+
+DESCRIPTION="A python utility/library to sort imports"
+HOMEPAGE="https://pypi.org/project/isort/"
+SRC_URI="https://github.com/timothycrosley/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/pipfile[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/backports-functools-lru-cache[${PYTHON_USEDEP}]' -2)
+"
+BDEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/isort-4.3.21_p1-tests.patch"
+)
+
+distutils_enable_tests pytest