summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-12 06:43:39 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-12 07:21:40 +0200
commit7796c84c6873e6bfa0d6e889f0110ecb5824f948 (patch)
treee9fc3d3c01d3c74d12aff1fdd051d6590768b104 /dev-python/jaraco-collections
parentapp-admin/awscli: Bump to 1.20.19 (diff)
downloadgentoo-7796c84c6873e6bfa0d6e889f0110ecb5824f948.tar.gz
gentoo-7796c84c6873e6bfa0d6e889f0110ecb5824f948.tar.bz2
gentoo-7796c84c6873e6bfa0d6e889f0110ecb5824f948.zip
dev-python/jaraco-collections: Remove pypy3 for the time being
Remove pypy3 and the relevant patch until the problem is resolved upstream. Apparently it was not even reported before, and the package does not have any pypy3-revdeps. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jaraco-collections')
-rw-r--r--dev-python/jaraco-collections/files/jaraco-collections-3.0.0-pypy.patch30
-rw-r--r--dev-python/jaraco-collections/jaraco-collections-3.3.0.ebuild6
2 files changed, 1 insertions, 35 deletions
diff --git a/dev-python/jaraco-collections/files/jaraco-collections-3.0.0-pypy.patch b/dev-python/jaraco-collections/files/jaraco-collections-3.0.0-pypy.patch
deleted file mode 100644
index 63cee6cb4115..000000000000
--- a/dev-python/jaraco-collections/files/jaraco-collections-3.0.0-pypy.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-diff --git a/jaraco/collections.py b/jaraco/collections.py
-index 3ab9dc9..6a6e342 100644
---- a/jaraco/collections.py
-+++ b/jaraco/collections.py
-@@ -4,6 +4,7 @@ import collections.abc
- import itertools
- import copy
- import functools
-+import platform
-
- from jaraco.classes.properties import NonDataProperty
- import jaraco.text
-@@ -592,9 +593,14 @@ class DictStack(list, collections.abc.Mapping):
- return list(set(itertools.chain.from_iterable(c.keys() for c in self)))
-
- def __getitem__(self, key):
-- for scope in reversed(self):
-- if key in scope:
-- return scope[key]
-+ if 'PyPy' in platform.python_implementation():
-+ for scope in reversed(list(self)):
-+ if key in scope:
-+ return scope[key]
-+ else:
-+ for scope in reversed(self):
-+ if key in scope:
-+ return scope[key]
- raise KeyError(key)
-
- push = list.append
diff --git a/dev-python/jaraco-collections/jaraco-collections-3.3.0.ebuild b/dev-python/jaraco-collections/jaraco-collections-3.3.0.ebuild
index a894279bf7a3..29c60505c72e 100644
--- a/dev-python/jaraco-collections/jaraco-collections-3.3.0.ebuild
+++ b/dev-python/jaraco-collections/jaraco-collections-3.3.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..10} pypy3 )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
MY_PN="${PN/-/.}"
@@ -24,10 +24,6 @@ BDEPEND="
>=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
"
-PATCHES=(
- "${FILESDIR}/jaraco-collections-3.0.0-pypy.patch"
-)
-
distutils_enable_sphinx docs '>=dev-python/jaraco-packaging-3.2' \
'>=dev-python/rst-linker-1.9'
distutils_enable_tests pytest