summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-09-06 23:40:03 +0200
committerGöktürk Yüksek <gokturk@gentoo.org>2016-09-08 23:47:36 -0400
commit996240f313076c09464e7cc59530e81ca47d7b48 (patch)
tree9c895053aeea9ba6ca10504dcf4501c1da3365b3 /dev-python/jaraco-functools/jaraco-functools-1.13.ebuild
parentapp-admin/cli53: bump to 0.8.2 (diff)
downloadgentoo-996240f313076c09464e7cc59530e81ca47d7b48.tar.gz
gentoo-996240f313076c09464e7cc59530e81ca47d7b48.tar.bz2
gentoo-996240f313076c09464e7cc59530e81ca47d7b48.zip
dev-python/jaraco-functools: bump to 1.13, add doc, changelog
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/jaraco-functools/jaraco-functools-1.13.ebuild')
-rw-r--r--dev-python/jaraco-functools/jaraco-functools-1.13.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/jaraco-functools/jaraco-functools-1.13.ebuild b/dev-python/jaraco-functools/jaraco-functools-1.13.ebuild
new file mode 100644
index 000000000000..3ff6ad8587ba
--- /dev/null
+++ b/dev-python/jaraco-functools/jaraco-functools-1.13.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Additional functions used by other projects by developer jaraco"
+HOMEPAGE="https://github.com/jaraco/jaraco.functools"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/backports-functools-lru-cache[${PYTHON_USEDEP}]' python2_7)
+"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-1.9[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/rst-linker[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${RDEPEND}
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ dev-python/backports-unittest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ PYTHONPATH=. py.test || die "tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
+ distutils-r1_python_install_all
+}