summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-29 21:03:26 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-29 21:03:26 +0300
commit009414de03de7d24f6d65c2d154f9b9c0ba51a25 (patch)
tree58a37da762312fa5b861060abe9d3b3e8d069457 /dev-python/jaraco-logging
parentdev-python/mkdocs-material: add 8.4.2 (diff)
downloadgentoo-009414de03de7d24f6d65c2d154f9b9c0ba51a25.tar.gz
gentoo-009414de03de7d24f6d65c2d154f9b9c0ba51a25.tar.bz2
gentoo-009414de03de7d24f6d65c2d154f9b9c0ba51a25.zip
dev-python/jaraco-logging: add 3.1.2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/jaraco-logging')
-rw-r--r--dev-python/jaraco-logging/Manifest1
-rw-r--r--dev-python/jaraco-logging/jaraco-logging-3.1.2.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/jaraco-logging/Manifest b/dev-python/jaraco-logging/Manifest
index bd27ff494286..3b3cd35adf73 100644
--- a/dev-python/jaraco-logging/Manifest
+++ b/dev-python/jaraco-logging/Manifest
@@ -1 +1,2 @@
DIST jaraco.logging-3.1.1.gh.tar.gz 10804 BLAKE2B 32d978ae8e9105986926649dcccd710aea44e2b8ea2f4b41dfdb6cb6512cc8597951909c4e217d608245fb37b29ced544429b4f960d080f5a3436f454d042826 SHA512 80cca221c713b3868ac06332451c2bf31cb3c95e27b82275a8cd70533cd790b4e420a5851c0a5ba067a85aa4efa266e38e2b5792e2a0e97fde158357b16b1794
+DIST jaraco.logging-3.1.2.gh.tar.gz 7193 BLAKE2B fab2b65f2cc40d96df1a145bd047aecfca9af8c54c438ec40f965c8698d5db328591c7857390638b6bb48d2faae5cd1ad4541f6eb7c3b85a7ca06d257ad15c98 SHA512 deebf628dd62b6948cdf12931018407de1fb653279e57efce0df1acdf11e4ebab33840ef1e1e452b711ddc70b62fe925ebaf49e065d3450a96f8f6c8bbb0120c
diff --git a/dev-python/jaraco-logging/jaraco-logging-3.1.2.ebuild b/dev-python/jaraco-logging/jaraco-logging-3.1.2.ebuild
new file mode 100644
index 000000000000..7c8eaa3c8628
--- /dev/null
+++ b/dev-python/jaraco-logging/jaraco-logging-3.1.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P="${P/-/.}"
+DESCRIPTION="Additional facilities to supplement Python's stdlib logging module"
+HOMEPAGE="
+ https://github.com/jaraco/jaraco.logging/
+ https://pypi.org/project/jaraco.logging/
+"
+SRC_URI="
+ https://github.com/jaraco/jaraco.logging/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/tempora[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ # create a pkgutil-style __init__.py in order to fix pytest's
+ # determination of package paths
+ cat > jaraco/__init__.py <<-EOF || die
+ __path__ = __import__("pkgutil").extend_path(__path__, __name__)
+ EOF
+ epytest --doctest-modules
+}