summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-18 07:51:22 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-18 07:54:46 +0200
commitcc53d23c59f9e1848044f4aa0b4c73178367722c (patch)
treeedba61d6515df70c413a3661f89a0d581f4207fb /dev-python/jaraco-packaging
parentdev-python/GitPython: Remove old (diff)
downloadgentoo-cc53d23c59f9e1848044f4aa0b4c73178367722c.tar.gz
gentoo-cc53d23c59f9e1848044f4aa0b4c73178367722c.tar.bz2
gentoo-cc53d23c59f9e1848044f4aa0b4c73178367722c.zip
dev-python/jaraco-packaging: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jaraco-packaging')
-rw-r--r--dev-python/jaraco-packaging/jaraco-packaging-8.1.0.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/dev-python/jaraco-packaging/jaraco-packaging-8.1.0.ebuild b/dev-python/jaraco-packaging/jaraco-packaging-8.1.0.ebuild
deleted file mode 100644
index a14d9974caad..000000000000
--- a/dev-python/jaraco-packaging/jaraco-packaging-8.1.0.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{6,7,8} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-MY_PN="${PN/-/.}"
-DESCRIPTION="Tools to supplement packaging Python releases"
-HOMEPAGE="https://github.com/jaraco/jaraco.packaging"
-SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv s390 sparc x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/importlib_metadata[${PYTHON_USEDEP}]
- >=dev-python/namespace-jaraco-2[${PYTHON_USEDEP}]
- >=dev-python/six-1.4[${PYTHON_USEDEP}]
-"
-DEPEND="
- dev-python/toml[${PYTHON_USEDEP}]
- >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_sphinx docs '>=dev-python/rst-linker-1.9'
-
-python_test() {
- # Skip one test which requires network access
- # Override pytest options to skip flake8
- PYTHONPATH=. pytest -vv -k "not test_revived_distribution" \
- --override-ini="addopts=--doctest-modules" \
- || die "tests failed with ${EPYTHON}"
-}
-
-# https://wiki.gentoo.org/wiki/Project:Python/Namespace_packages#File_collisions_between_pkgutil-style_packages
-python_install() {
- rm "${BUILD_DIR}"/lib/jaraco/__init__.py || die
- # note: eclass may default to --skip-build in the future
- distutils-r1_python_install --skip-build
-}