summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-06 07:55:38 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-06 09:16:00 +0200
commit2b14a578b1ab16b2d069fcfaad2f151469c12dd5 (patch)
tree89d044c0d5c74705bb0b79e539f0b633625dd3d4 /dev-python/jaraco-stream/jaraco-stream-3.0.3.ebuild
parentapp-admin/awscli: Bump to 1.20.55 (diff)
downloadgentoo-2b14a578b1ab16b2d069fcfaad2f151469c12dd5.tar.gz
gentoo-2b14a578b1ab16b2d069fcfaad2f151469c12dd5.tar.bz2
gentoo-2b14a578b1ab16b2d069fcfaad2f151469c12dd5.zip
dev-python/jaraco-stream: Bump to 3.0.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jaraco-stream/jaraco-stream-3.0.3.ebuild')
-rw-r--r--dev-python/jaraco-stream/jaraco-stream-3.0.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/jaraco-stream/jaraco-stream-3.0.3.ebuild b/dev-python/jaraco-stream/jaraco-stream-3.0.3.ebuild
new file mode 100644
index 000000000000..202efd87e748
--- /dev/null
+++ b/dev-python/jaraco-stream/jaraco-stream-3.0.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+inherit distutils-r1
+
+MY_P=${P/-/.}
+DESCRIPTION="Routines for handling streaming data"
+HOMEPAGE="https://github.com/jaraco/jaraco.stream"
+SRC_URI="mirror://pypi/${MY_P::1}/${PN/-/.}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ test? (
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ ">=dev-python/jaraco-packaging-3.2" \
+ ">=dev-python/rst-linker-1.9"
+distutils_enable_tests pytest