summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-08-15 20:24:45 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-08-15 20:30:46 +0300
commit4fbc4831e3cd87342ee327a6c1c5c81678db3177 (patch)
tree3049f4de517d65e7521ada6304e76d093250d208 /dev-python/jc
parentmedia-gfx/hydrus: Add 450 (diff)
downloadgentoo-4fbc4831e3cd87342ee327a6c1c5c81678db3177.tar.gz
gentoo-4fbc4831e3cd87342ee327a6c1c5c81678db3177.tar.bz2
gentoo-4fbc4831e3cd87342ee327a6c1c5c81678db3177.zip
dev-python/jc: add 1.16.0, enable py3.10, EAPI=8
Bug: https://bugs.gentoo.org/790707 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/jc')
-rw-r--r--dev-python/jc/Manifest1
-rw-r--r--dev-python/jc/jc-1.16.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/jc/Manifest b/dev-python/jc/Manifest
index d8eaec290703..42e0809b1010 100644
--- a/dev-python/jc/Manifest
+++ b/dev-python/jc/Manifest
@@ -1 +1,2 @@
DIST jc-1.15.3.tar.gz 131810 BLAKE2B 885e4910c1186dd9b8e42a2b06eeb954e777c5e6bc07575a3f5005ed575defbe1b9c21a34ba8ddb34812b60b139a41b3f79d74501e83ba38437a55746eaa36cc SHA512 f077253007185e34a9654551661b84625d312a0da3d7382ab30d6fb25c5d4d35cc021e6989937d1ab9b6826df7bd65654c4cb6b0a4f669c2abfc3350d3298f74
+DIST jc-1.16.0.tar.gz 2532019 BLAKE2B 583d52102a2e27a53171d300fb6e9ac094d5b09496193b359590322cab0f63582d14e0d27aacdd4f87e179cff1b0ffe0efc5bfc1982e64a7d053cf6210c2ed2a SHA512 a75c411d3f961061262b577e7a6611759f01df508e7d12e09cb364736dca343a098f9cbe4b2552ab2bd56fed925e7c11ba1f954808a11453380ba0ba0c32130b
diff --git a/dev-python/jc/jc-1.16.0.ebuild b/dev-python/jc/jc-1.16.0.ebuild
new file mode 100644
index 000000000000..7c7bc7a63e01
--- /dev/null
+++ b/dev-python/jc/jc-1.16.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Converts the output of popular command-line tools and file-types to JSON"
+HOMEPAGE="https://github.com/kellyjonbrazil/jc/tags"
+SRC_URI="https://github.com/kellyjonbrazil/jc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed -e "s|\\(^[[:space:]]*'[.[:alnum:]]\+\\)>=[^']*|\\1|" -i setup.py || die
+ distutils-r1_python_prepare_all
+}