summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-02 17:30:49 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-02 18:12:41 +0200
commitef29ef1b5de0e378b0ad12cea6c9e3087a88ce16 (patch)
tree806ae292a2dfc2e9cbf0f88673421ad8da77035e /dev-python/jeepney/jeepney-0.6.0.ebuild
parentdev-python/secretstorage: Enable py3.10 (diff)
downloadgentoo-ef29ef1b5de0e378b0ad12cea6c9e3087a88ce16.tar.gz
gentoo-ef29ef1b5de0e378b0ad12cea6c9e3087a88ce16.tar.bz2
gentoo-ef29ef1b5de0e378b0ad12cea6c9e3087a88ce16.zip
dev-python/jeepney: Run dbus-based tests too
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jeepney/jeepney-0.6.0.ebuild')
-rw-r--r--dev-python/jeepney/jeepney-0.6.0.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/dev-python/jeepney/jeepney-0.6.0.ebuild b/dev-python/jeepney/jeepney-0.6.0.ebuild
index 8a13adf05647..42dd4172cf33 100644
--- a/dev-python/jeepney/jeepney-0.6.0.ebuild
+++ b/dev-python/jeepney/jeepney-0.6.0.ebuild
@@ -21,6 +21,7 @@ BDEPEND="
test? (
dev-python/pytest-asyncio[${PYTHON_USEDEP}]
dev-python/testpath[${PYTHON_USEDEP}]
+ sys-apps/dbus
)
"
@@ -34,6 +35,10 @@ src_prepare() {
distutils-r1_src_prepare
}
+python_test() {
+ dbus-run-session pytest -vv -ra -l || die "tests failed with ${EPYTHON}"
+}
+
python_install_all() {
if use examples; then
docompress -x "/usr/share/doc/${PF}/examples"