summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-11 21:33:03 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-11 21:33:26 +0200
commit475ba8f640d223867defe0153849b2082dc5b3ae (patch)
tree3def45ea7d39514abb1594c9d06e002e1c41e5f5 /dev-python/jinja
parentdev-python/flask: Remove old (diff)
downloadgentoo-475ba8f640d223867defe0153849b2082dc5b3ae.tar.gz
gentoo-475ba8f640d223867defe0153849b2082dc5b3ae.tar.bz2
gentoo-475ba8f640d223867defe0153849b2082dc5b3ae.zip
dev-python/jinja: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jinja')
-rw-r--r--dev-python/jinja/Manifest1
-rw-r--r--dev-python/jinja/jinja-2.8.1.ebuild81
2 files changed, 0 insertions, 82 deletions
diff --git a/dev-python/jinja/Manifest b/dev-python/jinja/Manifest
index 162f85477e86..ec620108cd80 100644
--- a/dev-python/jinja/Manifest
+++ b/dev-python/jinja/Manifest
@@ -1,3 +1,2 @@
DIST jinja-2.11.1.tar.gz 258637 BLAKE2B 80826397ada553b2bd1452f72430589ddebbd55aecffe6c6d9161ddcb46d9caa35635abd0946e063efda856391843831d25a7de91250d0f066b12cbf8b4af988 SHA512 66d9b7923f4b78133489bc28525d83032d37d5409ac572c00ea1aa342b3291bf0505c1e9d62f7a553553e26f06885e3d5c71bdcd2b334064b610692681694d33
DIST jinja-2.11.2.tar.gz 258055 BLAKE2B 5cf12d6c79e7e659b16318cb3dc483a276511192903469629ec497c10ba6cd023f5a834961ac74cbda556177aaac46f5045c5aaca3068dcef87017760895851c SHA512 453e0c94c57065ab78f997726256bd2a31bb79124a2ee17b632cb124a3ccefded33d81b35cac73497f095b1cd5d8cd4420d6932a637fd7c4cdb786f1753e49ac
-DIST jinja-2.8.1.tar.gz 397144 BLAKE2B 78e4903da05ab3e8961b6bb6047116941b4bbf59d08b8283582972590409f98b5dc1f468a988525d96c552000279fcd0a31dae3ac1e5226f609a8854c8f9ca0b SHA512 f4655f1a43c06f7651fbd5251d0538788a3a6a3ffb93d9a8c239711cf043082c43d34706b6d71a18679d957faa6590e7e0259ffb8f7cc5e3300749526417a987
diff --git a/dev-python/jinja/jinja-2.8.1.ebuild b/dev-python/jinja/jinja-2.8.1.ebuild
deleted file mode 100644
index cf1ca69bbed4..000000000000
--- a/dev-python/jinja/jinja-2.8.1.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="A full-featured template engine for Python"
-HOMEPAGE="http://jinja.pocoo.org/ https://pypi.org/project/Jinja2/"
-
-# pypi tarball is missing tests
-SRC_URI="https://github.com/pallets/jinja/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
-IUSE="examples test"
-RESTRICT="!test? ( test )"
-
-CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- !dev-python/jinja:compat"
-RDEPEND="${CDEPEND}
- dev-python/markupsafe[${PYTHON_USEDEP}]"
-BDEPEND="${CDEPEND}"
-
-distutils_enable_sphinx docs \
- dev-python/sphinx-issues \
- dev-python/pallets-sphinx-themes
-distutils_enable_tests pytest
-
-# XXX: handle Babel better?
-
-wrap_opts() {
- local mydistutilsargs=()
-
- if [[ ${EPYTHON} == python* ]]; then
- mydistutilargs+=( --with-debugsupport )
- fi
-
- "${@}"
-}
-
-src_prepare() {
- # avoid unnecessary dep on extra sphinxcontrib modules
- sed -i '/sphinxcontrib.log_cabinet/ d' docs/conf.py || die
- printf "############################# SED ###############################\n"
-
- distutils-r1_src_prepare
-}
-
-python_prepare() {
- # async is not supported on python2
- if ! python_is_python3; then
- rm -f jinja2/async*.py || die "Failed to remove async from python2"
- fi
-}
-
-python_compile() {
- wrap_opts distutils-r1_python_compile
-}
-
-python_install_all() {
- if use examples ; then
- docinto examples
- dodoc -r examples/.
- fi
-
- distutils-r1_python_install_all
-
- insinto /usr/share/vim/vimfiles/syntax
- doins ext/Vim/*
-}
-
-pkg_postinst() {
- if ! has_version dev-python/Babel; then
- elog "For i18n support, please emerge dev-python/Babel."
- fi
-}