summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-06-24 16:49:41 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-06-24 16:51:42 +0200
commitef56fc17172b0f6eb12b4ccaa1492c7d8350e307 (patch)
tree1096a2afb8288c785029b7aaae8d761da8ec1fb9 /dev-python/jpype
parentapp-admin/newsyslog: version bump. (diff)
downloadgentoo-ef56fc17172b0f6eb12b4ccaa1492c7d8350e307.tar.gz
gentoo-ef56fc17172b0f6eb12b4ccaa1492c7d8350e307.tar.bz2
gentoo-ef56fc17172b0f6eb12b4ccaa1492c7d8350e307.zip
dev-python/jpype: version bump.
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-python/jpype')
-rw-r--r--dev-python/jpype/Manifest1
-rw-r--r--dev-python/jpype/jpype-0.6.3.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/jpype/Manifest b/dev-python/jpype/Manifest
index a9bcf30b71b1..c897916a39f5 100644
--- a/dev-python/jpype/Manifest
+++ b/dev-python/jpype/Manifest
@@ -1,2 +1,3 @@
DIST jpype-0.6.1.zip 251407 BLAKE2B 9dc866c1dc48a3c7d62fcbcfb84ada447285c59aaac02d551054d02c40ebd32f9fc662c8da371a35679d7b54e333c2da88025961aa5808d158967d16c5f2af06 SHA512 e3cdae95a394f5b57049f444e4da442a75938279f77d74304ac6a45bf00eb4110d3a63b5580e30d82777764f195f848639f6b4e973e48510d0f5cd60c475ce2f
DIST jpype-0.6.2.zip 260812 BLAKE2B 1e432e9d299b88d8205a2f8088123b61460772abf4fb04b5094f15c69d205d3393c2b9a31654bcfa7be4ee85d3acb702960526a14d95018c48dd012665e858f4 SHA512 f4ce5fe6e0f920f6c17bc8815c09fb54909f105fb4cf022856482680f24305a002ce00354cf44c730b34220d12f1d926971b246d0a938bb411401b0656486091
+DIST jpype-0.6.3.tar.gz 169886 BLAKE2B 26a7cd583bfb40333de99658130a6672c87998472fbfea12de888bfe9a054206d13d8b57896a7b74b79d38280f516cb6e498cd2b1d7549930ded5bcc615619a4 SHA512 49664083db6db309c56068ace713059be1fede721c7368fb3fa0ed5cde0aeb6782b2953be9c0d71f8f8028e909e67e525338da0797a5b4bcfc2325614d5849cc
diff --git a/dev-python/jpype/jpype-0.6.3.ebuild b/dev-python/jpype/jpype-0.6.3.ebuild
new file mode 100644
index 000000000000..4b7d9123cd1d
--- /dev/null
+++ b/dev-python/jpype/jpype-0.6.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit java-pkg-2 distutils-r1
+
+DESCRIPTION="JPype is an effort to allow Python programs full access to Java class librairies"
+HOMEPAGE="https://github.com/originell/jpype"
+SRC_URI="https://github.com/originell/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+S="${WORKDIR}/${P}"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=virtual/jdk-1.6"
+
+#PATCHES=( "${FILESDIR}"/${PN}-gcc6-noexcept.patch )
+
+python_compile() {
+ if ! python_is_python3; then
+ local CXXFLAGS="${CXXFLAGS} -fno-strict-aliasing"
+ export CXXFLAGS
+ fi
+ distutils-r1_python_compile
+}
+
+python_install() {
+ use doc && local DOCS=( doc/* )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install
+}