summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-19 07:37:13 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-19 07:40:40 +0100
commitbe8e7594c4887aae23be3790e13423bb242acf44 (patch)
tree4b5d8f7f8f10a0c29c4ed0af303e762275e01532 /dev-python/jsmin
parentpackage.mask: Rescue dev-python/jsmin (diff)
downloadgentoo-be8e7594c4887aae23be3790e13423bb242acf44.tar.gz
gentoo-be8e7594c4887aae23be3790e13423bb242acf44.tar.bz2
gentoo-be8e7594c4887aae23be3790e13423bb242acf44.zip
dev-python/jsmin: Modernize, py3.{7,8}
Bug: https://bugs.gentoo.org/711808 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jsmin')
-rw-r--r--dev-python/jsmin/jsmin-2.2.2.ebuild8
1 files changed, 3 insertions, 5 deletions
diff --git a/dev-python/jsmin/jsmin-2.2.2.ebuild b/dev-python/jsmin/jsmin-2.2.2.ebuild
index 76dc206a48e6..4a73f6c17ca0 100644
--- a/dev-python/jsmin/jsmin-2.2.2.ebuild
+++ b/dev-python/jsmin/jsmin-2.2.2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{6,7,8} )
inherit distutils-r1
@@ -16,8 +16,6 @@ IUSE=""
LICENSE="MIT"
SLOT="0"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
python_test() {
- "${PYTHON}" -m ${PN}.test || die
+ "${EPYTHON}" -m jsmin.test -v || die "Tests failed with ${EPYTHON}"
}