summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-19 22:50:51 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-19 23:22:46 +0200
commit03011671a924070a92672e6b19cd2aeca59e0bb5 (patch)
treef0895900dee06090ea88b51ebc24a417e6f61d98 /dev-python/jsondiff
parentmail-client/thunderbird-bin: bump to v78.10.0 (diff)
downloadgentoo-03011671a924070a92672e6b19cd2aeca59e0bb5.tar.gz
gentoo-03011671a924070a92672e6b19cd2aeca59e0bb5.tar.bz2
gentoo-03011671a924070a92672e6b19cd2aeca59e0bb5.zip
dev-python/jsondiff: Bump to 1.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jsondiff')
-rw-r--r--dev-python/jsondiff/Manifest1
-rw-r--r--dev-python/jsondiff/jsondiff-1.3.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/jsondiff/Manifest b/dev-python/jsondiff/Manifest
index dc2455ef7c1b..2311d358b58c 100644
--- a/dev-python/jsondiff/Manifest
+++ b/dev-python/jsondiff/Manifest
@@ -1 +1,2 @@
DIST jsondiff-1.2.0.tar.gz 15076 BLAKE2B 2d659598e6c647c8ea6622fc982808381e570c6ced23b5e77431b52e9fa746a5dbc743c739506362497d1f45dd2c290f23f459713ef31e927c05816e56659762 SHA512 5aa391ccc42d07330dfcf272b78aeb130f6f9033ca8b00cbea93549e32f07b98ea84cd6a1e61ab331da3de92838c69a501f95a9adb5f48e2eec46eb653264d55
+DIST jsondiff-1.3.0.tar.gz 15283 BLAKE2B 408070816a4b21a3f11f5b039464ba276fb253f712f29930454167d3aff22f78b4d828aba5e28cf05587c8a296b908fd1945a65958244a1093279bff5e3a555c SHA512 512e34d1a0673ed785f066c284c09412a3590ad916913ae1885ac567795cc73e2adf30596b60b64b6b379954e6cb82d5174e80dd9cf40ed53f6968bec8a3d8f2
diff --git a/dev-python/jsondiff/jsondiff-1.3.0.ebuild b/dev-python/jsondiff/jsondiff-1.3.0.ebuild
new file mode 100644
index 000000000000..719f5a89b88a
--- /dev/null
+++ b/dev-python/jsondiff/jsondiff-1.3.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Diff JSON and JSON-like structures in Python"
+HOMEPAGE="
+ https://github.com/xlwings/jsondiff/
+ https://pypi.org/project/jsondiff/"
+SRC_URI="
+ https://github.com/fzumstein/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ test? (
+ dev-python/nose-random[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # Avoid file collision with jsonpatch's jsondiff cli.
+ sed -e "/'jsondiff=jsondiff.cli/ d" -i setup.py || die
+ distutils-r1_python_prepare_all
+}