summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zachary.medico@sony.com>2019-06-18 20:32:15 -0700
committerZac Medico <zmedico@gentoo.org>2019-06-24 18:33:41 -0700
commit6a74863a18d198c21f898be378379ca8675e5e96 (patch)
treebb78ce0fa57e0708a3f82e82768eb81fb0ee51c4 /dev-python/jsondiff
parentdev-python/aws-xray-sdk-python: New package (diff)
downloadgentoo-6a74863a18d198c21f898be378379ca8675e5e96.tar.gz
gentoo-6a74863a18d198c21f898be378379ca8675e5e96.tar.bz2
gentoo-6a74863a18d198c21f898be378379ca8675e5e96.zip
dev-python/jsondiff: New package
Bug: https://bugs.gentoo.org/688034 Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'dev-python/jsondiff')
-rw-r--r--dev-python/jsondiff/Manifest1
-rw-r--r--dev-python/jsondiff/jsondiff-1.1.2.ebuild33
-rw-r--r--dev-python/jsondiff/metadata.xml13
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/jsondiff/Manifest b/dev-python/jsondiff/Manifest
new file mode 100644
index 000000000000..ec5b32ac77ee
--- /dev/null
+++ b/dev-python/jsondiff/Manifest
@@ -0,0 +1 @@
+DIST jsondiff-1.1.2.tar.gz 7803 BLAKE2B cbfcfdb2c6c3bb721b4db43aca1d66649257db2cd9feb9655015e621fcd90c72af087696b9553a10ac89cdaf5f23d8748463e1a13bdb19207e34e12e66629544 SHA512 ca96bb80a6f7a34c8c5bcde74856dc1c4935b3e2979330ecfc33432aff83968e671b2aaf310c77f2c7d431be1ae6e20a960879700ba3c903a09a48b23d4c0288
diff --git a/dev-python/jsondiff/jsondiff-1.1.2.ebuild b/dev-python/jsondiff/jsondiff-1.1.2.ebuild
new file mode 100644
index 000000000000..4f246f930991
--- /dev/null
+++ b/dev-python/jsondiff/jsondiff-1.1.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Diff JSON and JSON-like structures in Python"
+HOMEPAGE="https://github.com/xlwings/jsondiff https://pypi.org/project/jsondiff/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+# tests require nose_random
+RESTRICT="test"
+
+python_prepare_all() {
+ # Avoid file collision with jsonpatch's jsondiff cli.
+ sed -e "/'jsondiff=jsondiff.cli:main'/d" -i setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test || die "tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/jsondiff/metadata.xml b/dev-python/jsondiff/metadata.xml
new file mode 100644
index 000000000000..ff1d5858ae38
--- /dev/null
+++ b/dev-python/jsondiff/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zmedico@gentoo.org</email>
+ <name>Zac Medico</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">xlwings/jsondiff</remote-id>
+ <remote-id type="pypi">jsondiff</remote-id>
+ <bugs-to>https://github.com/xlwings/jsondiff/issues</bugs-to>
+ </upstream>
+</pkgmetadata>