summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-01-24 19:56:31 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-01-24 19:56:31 +0200
commit73969f942d12974528b7c78d0b6514669ded79a0 (patch)
treedcaac1e392387a110f599d3f67ee3592ede73154 /dev-python/jsondiff
parentdev-python/django-taggit: add 2.1.0 (diff)
downloadgentoo-73969f942d12974528b7c78d0b6514669ded79a0.tar.gz
gentoo-73969f942d12974528b7c78d0b6514669ded79a0.tar.bz2
gentoo-73969f942d12974528b7c78d0b6514669ded79a0.zip
dev-python/jsondiff: add 1.3.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/jsondiff')
-rw-r--r--dev-python/jsondiff/Manifest1
-rw-r--r--dev-python/jsondiff/jsondiff-1.3.1.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/jsondiff/Manifest b/dev-python/jsondiff/Manifest
index 2fc30e8ea083..6b8c544f7e1f 100644
--- a/dev-python/jsondiff/Manifest
+++ b/dev-python/jsondiff/Manifest
@@ -1 +1,2 @@
DIST jsondiff-1.3.0.tar.gz 15283 BLAKE2B 408070816a4b21a3f11f5b039464ba276fb253f712f29930454167d3aff22f78b4d828aba5e28cf05587c8a296b908fd1945a65958244a1093279bff5e3a555c SHA512 512e34d1a0673ed785f066c284c09412a3590ad916913ae1885ac567795cc73e2adf30596b60b64b6b379954e6cb82d5174e80dd9cf40ed53f6968bec8a3d8f2
+DIST jsondiff-1.3.1.gh.tar.gz 15457 BLAKE2B f3896c85b601ac32859e59f2a5a29b51f124a1dd27fa2b0da40e44c4b776bbba933043fb7334e5ec20833eea25143d40cc7988a8308f56eff20510db982688b0 SHA512 cbbed17bf00f1757d81477e02435c3f5a9a3246774f3fd9a433be31de1617525acfe33d6790be33dcf9b5da5ef3d6910d13958fb7b8ea4fbd802c74485a9dc6f
diff --git a/dev-python/jsondiff/jsondiff-1.3.1.ebuild b/dev-python/jsondiff/jsondiff-1.3.1.ebuild
new file mode 100644
index 000000000000..3780ec828dbf
--- /dev/null
+++ b/dev-python/jsondiff/jsondiff-1.3.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Diff JSON and JSON-like structures in Python"
+HOMEPAGE="
+ https://github.com/xlwings/jsondiff/
+ https://pypi.org/project/jsondiff/"
+SRC_URI="
+ https://github.com/xlwings/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ test? (
+ dev-python/nose-random[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # Avoid file collision with jsonpatch's jsondiff cli.
+ sed -e "/'jsondiff=jsondiff.cli/ d" -i setup.py || die
+ distutils-r1_python_prepare_all
+}