summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-14 08:50:22 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-14 08:50:22 +0100
commit1fd0b952862273476933a7cc8a4315ddba8ba7df (patch)
treefcadf44823aa9fa0a327d18ff6249f989e0eba79 /dev-python/jsonpointer
parentdev-python/jsonpatch: Bump to 1.32 (diff)
downloadgentoo-1fd0b952862273476933a7cc8a4315ddba8ba7df.tar.gz
gentoo-1fd0b952862273476933a7cc8a4315ddba8ba7df.tar.bz2
gentoo-1fd0b952862273476933a7cc8a4315ddba8ba7df.zip
dev-python/jsonpointer: Bump to 2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jsonpointer')
-rw-r--r--dev-python/jsonpointer/Manifest1
-rw-r--r--dev-python/jsonpointer/jsonpointer-2.1.ebuild19
2 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/jsonpointer/Manifest b/dev-python/jsonpointer/Manifest
index fcaf0117e116..256a7173a8c9 100644
--- a/dev-python/jsonpointer/Manifest
+++ b/dev-python/jsonpointer/Manifest
@@ -1 +1,2 @@
DIST jsonpointer-2.0.tar.gz 8699 BLAKE2B 7b52955aa691a1bba327df6674704503b009101d0dd94587620a684ca9310128e3afcc62cedabd92106deffc3a6a3434a72123fc804224ae68ade8751462bf14 SHA512 e8e2b03c12c3fc5f65816fc71d1c07135ef74a0c912286f5b8bef2d9e21b8ae6e766d1aa2104b3eeb0e53928034321f25b203386ac3f5641b54b0641f6a08137
+DIST jsonpointer-2.1.tar.gz 8190 BLAKE2B 5b9d0b0a27c6e2d133de67cf0ff9442e639a06011005f94cb425568fd3e5678b4832e9467720261fb85669e8b83eac73b1cfa8058adbd78d46339cdf8359561c SHA512 4eed8c7fa908ce3ca79884e98b1b0e818d24515f6b7b2067daa49ab6dbd989be4bc43f387e980773c9fc17bca89d2039750cb0df76675259050e3f48c16da3b6
diff --git a/dev-python/jsonpointer/jsonpointer-2.1.ebuild b/dev-python/jsonpointer/jsonpointer-2.1.ebuild
new file mode 100644
index 000000000000..fa4a6245c51e
--- /dev/null
+++ b/dev-python/jsonpointer/jsonpointer-2.1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Identify specific nodes in a JSON document (according to draft 08)"
+HOMEPAGE="https://github.com/stefankoegl/python-json-pointer https://pypi.org/project/jsonpointer/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+python_test() {
+ "${EPYTHON}" tests.py || die "Tests fail with ${EPYTHON}"
+}