summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/jsonpointer
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/jsonpointer')
-rw-r--r--dev-python/jsonpointer/Manifest2
-rw-r--r--dev-python/jsonpointer/jsonpointer-1.7.ebuild24
-rw-r--r--dev-python/jsonpointer/jsonpointer-1.9.ebuild23
-rw-r--r--dev-python/jsonpointer/metadata.xml17
4 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/jsonpointer/Manifest b/dev-python/jsonpointer/Manifest
new file mode 100644
index 000000000000..e8ca3b2b7ef7
--- /dev/null
+++ b/dev-python/jsonpointer/Manifest
@@ -0,0 +1,2 @@
+DIST jsonpointer-1.7.tar.gz 8187 SHA256 46b2016b5e4f2b5cd2edf07c60ca8fe7dd91204ca848f98964be61b3c4760f5e SHA512 26b25f31fb98fe7c7d926dcc492fe7889f2462430f959645e498fc47367d23243fb3b528da7af026827dffb30d7c5fe2ffb31843a8f2c9064647bebb313de9bb WHIRLPOOL 8539c4bb40cb2c1042f76d91e127da31d742ea55f8b2ba51abcc0e2d3319bf2ab2380e3ee2cd4195d8cc563b2d36a1eff56a6e72e2f3a8c171692bb66bfa3558
+DIST jsonpointer-1.9.tar.gz 7662 SHA256 39403b47a71aa782de6d80db3b78f8a5f68ad8dfc9e674ca3bb5b32c15ec7308 SHA512 872367c1a75f8022c07a52191d3f9491dd62767f58c4fa2c2fdcd1bf139858f73e7a5ad495943f1cb35b759d7919a807f8bccc052f6c35831e8091b5fda31b40 WHIRLPOOL bfe55984774502e8e91471d00d4d63bb3bf224cc3e677c1d20ee1e060962b7c9962577bbbdaba5c18647d588878820dc1f7b21ad206da019acf79ad9ba289e84
diff --git a/dev-python/jsonpointer/jsonpointer-1.7.ebuild b/dev-python/jsonpointer/jsonpointer-1.7.ebuild
new file mode 100644
index 000000000000..5a70a32ce7c7
--- /dev/null
+++ b/dev-python/jsonpointer/jsonpointer-1.7.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Identify specific nodes in a JSON document (according to draft 08)"
+HOMEPAGE="https://github.com/stefankoegl/python-json-pointer https://pypi.python.org/pypi/jsonpointer/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+python_test() {
+ "${PYTHON}" tests.py || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/jsonpointer/jsonpointer-1.9.ebuild b/dev-python/jsonpointer/jsonpointer-1.9.ebuild
new file mode 100644
index 000000000000..0c784a0711d2
--- /dev/null
+++ b/dev-python/jsonpointer/jsonpointer-1.9.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Identify specific nodes in a JSON document (according to draft 08)"
+HOMEPAGE="https://github.com/stefankoegl/python-json-pointer https://pypi.python.org/pypi/jsonpointer/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${PYTHON}" tests.py || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/jsonpointer/metadata.xml b/dev-python/jsonpointer/metadata.xml
new file mode 100644
index 000000000000..4682e7f37ec5
--- /dev/null
+++ b/dev-python/jsonpointer/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ Identify specific nodes in a JSON document (according to draft 08)
+ http://tools.ietf.org/html/draft-ietf-appsawg-json-pointer-08
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">jsonpointer</remote-id>
+ <remote-id type="github">stefankoegl/python-json-pointer</remote-id>
+ </upstream>
+</pkgmetadata>