summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-09 22:26:39 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-09 22:26:39 +0100
commitbc0fd965ae43afb491b4c68155b64b1d567b040c (patch)
treeffa928af287770132d729934088c3679438bacd7 /dev-python/jsonrpclib/jsonrpclib-0.4.2.ebuild
parentxfce-extra/xfce4-weather-plugin: Bump to 0.10.2 (diff)
downloadgentoo-bc0fd965ae43afb491b4c68155b64b1d567b040c.tar.gz
gentoo-bc0fd965ae43afb491b4c68155b64b1d567b040c.tar.bz2
gentoo-bc0fd965ae43afb491b4c68155b64b1d567b040c.zip
dev-python/jsonrpclib: Bump to 0.4.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jsonrpclib/jsonrpclib-0.4.2.ebuild')
-rw-r--r--dev-python/jsonrpclib/jsonrpclib-0.4.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/jsonrpclib/jsonrpclib-0.4.2.ebuild b/dev-python/jsonrpclib/jsonrpclib-0.4.2.ebuild
new file mode 100644
index 000000000000..3caeeb9a0089
--- /dev/null
+++ b/dev-python/jsonrpclib/jsonrpclib-0.4.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/tcalmant/jsonrpclib.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/tcalmant/jsonrpclib/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+fi
+
+DESCRIPTION="python implementation of the JSON-RPC spec (1.0 and 2.0)"
+HOMEPAGE="https://github.com/tcalmant/jsonrpclib"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/simplejson[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )"
+
+python_test() {
+ esetup.py test
+}