summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2017-12-16 23:47:28 -0500
committerAnthony G. Basile <blueness@gentoo.org>2017-12-16 23:47:28 -0500
commitef2e2f446ec9ddd4a61c497c13dd3ea15e1923f6 (patch)
tree37a90fea5a275465f9e65fbbfb8b0ab0f531b316 /dev-python/jsonrpclib/jsonrpclib-9999.ebuild
parentnet-misc/electrum: minor cleanups on 3.0.3 (diff)
downloadgentoo-ef2e2f446ec9ddd4a61c497c13dd3ea15e1923f6.tar.gz
gentoo-ef2e2f446ec9ddd4a61c497c13dd3ea15e1923f6.tar.bz2
gentoo-ef2e2f446ec9ddd4a61c497c13dd3ea15e1923f6.zip
dev-python/jsonrpclib: switch from joshmarshall to tcalmant
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'dev-python/jsonrpclib/jsonrpclib-9999.ebuild')
-rw-r--r--dev-python/jsonrpclib/jsonrpclib-9999.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/dev-python/jsonrpclib/jsonrpclib-9999.ebuild b/dev-python/jsonrpclib/jsonrpclib-9999.ebuild
index 0f9b2831c048..de6e1a8301bc 100644
--- a/dev-python/jsonrpclib/jsonrpclib-9999.ebuild
+++ b/dev-python/jsonrpclib/jsonrpclib-9999.ebuild
@@ -2,20 +2,20 @@
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
inherit distutils-r1
if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/joshmarshall/jsonrpclib.git"
+ EGIT_REPO_URI="https://github.com/tcalmant/jsonrpclib.git"
inherit git-r3
else
- SRC_URI="https://github.com/joshmarshall/jsonrpclib/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/tcalmant/jsonrpclib/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~mips ~x86"
fi
DESCRIPTION="python implementation of the JSON-RPC spec (1.0 and 2.0)"
-HOMEPAGE="https://github.com/joshmarshall/jsonrpclib"
+HOMEPAGE="https://github.com/tcalmant/jsonrpclib"
LICENSE="Apache-2.0"
SLOT="0"
@@ -24,3 +24,7 @@ IUSE=""
DEPEND=""
RDEPEND="${DEPEND}
dev-python/simplejson"
+
+python_test() {
+ esetup.py test || die "tests failed with ${EPYTHON}"
+}