summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-10 23:02:54 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-11 00:22:38 +0100
commit064af661d0c9a31cecdf348632bc5603333a9149 (patch)
tree2202373a7cafcb8a761d32747d4f62263aed64d5 /dev-python/jsonschema
parentdev-python/passlib: keyworded 1.7.1-r2 for hppa, bug #700918 (diff)
downloadgentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.gz
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.bz2
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.zip
*/*: [QA] Fix trivial cases of MissingTestRestrict
The result was achieved via the following pipeline: pkgcheck scan -c RestrictTestCheck -R FormatReporter \ --format '{category}/{package}/{package}-{version}.ebuild' | xargs -n32 grep -L RESTRICT | xargs -n32 sed -i -e '/^IUSE=.*test/aRESTRICT="!test? ( test )"' The resulting metadata was compared before and after the change. Few Go ebuilds had to be fixed manually due to implicit RESTRICT=strip added by the eclass. Two ebuilds have to be fixed because of multiline IUSE. Suggested-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/13942 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jsonschema')
-rw-r--r--dev-python/jsonschema/jsonschema-2.3.0.ebuild1
-rw-r--r--dev-python/jsonschema/jsonschema-2.4.0.ebuild1
-rw-r--r--dev-python/jsonschema/jsonschema-2.5.1-r2.ebuild1
-rw-r--r--dev-python/jsonschema/jsonschema-2.6.0.ebuild1
-rw-r--r--dev-python/jsonschema/jsonschema-3.0.1.ebuild1
5 files changed, 5 insertions, 0 deletions
diff --git a/dev-python/jsonschema/jsonschema-2.3.0.ebuild b/dev-python/jsonschema/jsonschema-2.3.0.ebuild
index e5f7a0fce812..732de0fec5cb 100644
--- a/dev-python/jsonschema/jsonschema-2.3.0.ebuild
+++ b/dev-python/jsonschema/jsonschema-2.3.0.ebuild
@@ -13,6 +13,7 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
IUSE="test"
+RESTRICT="!test? ( test )"
python_test() {
local runner=( "${PYTHON}" -m unittest )
diff --git a/dev-python/jsonschema/jsonschema-2.4.0.ebuild b/dev-python/jsonschema/jsonschema-2.4.0.ebuild
index 29edeff73466..b027d9ef7817 100644
--- a/dev-python/jsonschema/jsonschema-2.4.0.ebuild
+++ b/dev-python/jsonschema/jsonschema-2.4.0.ebuild
@@ -15,6 +15,7 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
IUSE="test"
+RESTRICT="!test? ( test )"
python_test() {
"${PYTHON}" -m unittest discover || die "Testing failed with ${EPYTHON}"
diff --git a/dev-python/jsonschema/jsonschema-2.5.1-r2.ebuild b/dev-python/jsonschema/jsonschema-2.5.1-r2.ebuild
index dd7476a301ad..fc1012c726fb 100644
--- a/dev-python/jsonschema/jsonschema-2.5.1-r2.ebuild
+++ b/dev-python/jsonschema/jsonschema-2.5.1-r2.ebuild
@@ -15,6 +15,7 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="alpha amd64 ~arm arm64 hppa ia64 m68k ~mips ppc ppc64 ~s390 sh sparc x86 ~amd64-linux ~x86-linux"
IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND="
dev-python/rfc3986[${PYTHON_USEDEP}]
diff --git a/dev-python/jsonschema/jsonschema-2.6.0.ebuild b/dev-python/jsonschema/jsonschema-2.6.0.ebuild
index 4664194e869c..d7cd1854e4ae 100644
--- a/dev-python/jsonschema/jsonschema-2.6.0.ebuild
+++ b/dev-python/jsonschema/jsonschema-2.6.0.ebuild
@@ -15,6 +15,7 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-linux ~x86-linux"
IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND="
dev-python/rfc3987[${PYTHON_USEDEP}]
diff --git a/dev-python/jsonschema/jsonschema-3.0.1.ebuild b/dev-python/jsonschema/jsonschema-3.0.1.ebuild
index 38e779523d74..a642c5eee676 100644
--- a/dev-python/jsonschema/jsonschema-3.0.1.ebuild
+++ b/dev-python/jsonschema/jsonschema-3.0.1.ebuild
@@ -15,6 +15,7 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
IUSE="test"
+RESTRICT="!test? ( test )"
BDEPEND="
dev-python/setuptools_scm[${PYTHON_USEDEP}]