summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-05 00:08:31 +0100
committerSam James <sam@gentoo.org>2021-10-05 00:08:57 +0100
commit8d1565036fc38b87d11a49d031608b1601d40d3b (patch)
treef48a668ca67b8c67bc15d49e032589008ffa96ca /dev-python/jsonschema
parentdev-python/python-ironicclient: Keyword 4.8.0 arm, #815481 (diff)
downloadgentoo-8d1565036fc38b87d11a49d031608b1601d40d3b.tar.gz
gentoo-8d1565036fc38b87d11a49d031608b1601d40d3b.tar.bz2
gentoo-8d1565036fc38b87d11a49d031608b1601d40d3b.zip
dev-python/jsonschema: add 4.0.1
Very minor changes (metadata). Closes: https://bugs.gentoo.org/815415 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/jsonschema')
-rw-r--r--dev-python/jsonschema/Manifest1
-rw-r--r--dev-python/jsonschema/jsonschema-4.0.1.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/jsonschema/Manifest b/dev-python/jsonschema/Manifest
index 5643cf9fcebe..a3df46c46c0c 100644
--- a/dev-python/jsonschema/Manifest
+++ b/dev-python/jsonschema/Manifest
@@ -1,2 +1,3 @@
DIST jsonschema-3.2.0.tar.gz 167226 BLAKE2B f89a8198f6b7b4dd56b0320ddecdd834423cbeaf49fbbd1563007da61004322b92e25856ecc17b4d02e2162b2359ec5d7601826fe42cfcb7683ae16cf2baeb39 SHA512 acbb4cec730a8cdab9f070593ed896064fbe082d464ec362adc952e4985e9eaa12ad0f2d55a04018ffdaf675e54037999a7219533dad6b84bf609f5dfe21bbab
DIST jsonschema-4.0.0.tar.gz 290808 BLAKE2B 29b53fcdedd170d1ea8602dd706d671b78394b8d5e5f54ae3443269394bb7a4d8399a2d99a87dfbb4d27d6613b47e0d5a1c6caea9b679cfd1d21cb4ee0f4e45c SHA512 5decad39032a229f992bf25555473171a19ae076a0726b73fcc284cecf788bcd29e8662ad48405ee5a93df812b87e5846a640dafc32157c3742f2abf7f7a9c97
+DIST jsonschema-4.0.1.tar.gz 290999 BLAKE2B d693a33ef705a401187bdf603aacfd0336eab16afc0e38c5133ff6a74e4f0b323172d5abac0959163e40f546eedb75fe2b71f2ca53e7bbe1bf4f00ad977873b9 SHA512 50a2dd6423e8aca76e0a33e33a63bb7d1500abac891076426112c4577277d1f0322d06ec0ba5a9f47c65e5981f0cce768801e55e2f03ab6b0b6d2f884249b5fb
diff --git a/dev-python/jsonschema/jsonschema-4.0.1.ebuild b/dev-python/jsonschema/jsonschema-4.0.1.ebuild
new file mode 100644
index 000000000000..66da5466d223
--- /dev/null
+++ b/dev-python/jsonschema/jsonschema-4.0.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="An implementation of JSON-Schema validation for Python"
+HOMEPAGE="https://pypi.org/project/jsonschema/ https://github.com/Julian/jsonschema"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ >=dev-python/pyrsistent-0.18.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+ ' pypy3)
+"
+
+# formatter deps
+RDEPEND+="
+ dev-python/fqdn[${PYTHON_USEDEP}]
+ dev-python/idna[${PYTHON_USEDEP}]
+ dev-python/isoduration[${PYTHON_USEDEP}]
+ >=dev-python/jsonpointer-1.13[${PYTHON_USEDEP}]
+ dev-python/rfc3339-validator[${PYTHON_USEDEP}]
+ dev-python/rfc3986-validator[${PYTHON_USEDEP}]
+ dev-python/rfc3987[${PYTHON_USEDEP}]
+ dev-python/uritemplate[${PYTHON_USEDEP}]
+ >=dev-python/webcolors-1.11[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/twisted[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests --install unittest