summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-20 22:53:35 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-20 23:43:30 +0200
commitea9da8ee6a223d2f818de31f6db5877a95a34462 (patch)
tree7a4b0cad7874b634ed8def3ba5a665cb5eeaad16 /dev-python/jsonschema
parentdev-python/xmlschema: Bump to 1.8.1 (diff)
downloadgentoo-ea9da8ee6a223d2f818de31f6db5877a95a34462.tar.gz
gentoo-ea9da8ee6a223d2f818de31f6db5877a95a34462.tar.bz2
gentoo-ea9da8ee6a223d2f818de31f6db5877a95a34462.zip
dev-python/jsonschema: Bump to 4.1.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jsonschema')
-rw-r--r--dev-python/jsonschema/Manifest1
-rw-r--r--dev-python/jsonschema/jsonschema-4.1.2.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/jsonschema/Manifest b/dev-python/jsonschema/Manifest
index 0ac076a08062..dcc3340564f1 100644
--- a/dev-python/jsonschema/Manifest
+++ b/dev-python/jsonschema/Manifest
@@ -2,3 +2,4 @@ DIST jsonschema-3.2.0.tar.gz 167226 BLAKE2B f89a8198f6b7b4dd56b0320ddecdd834423c
DIST jsonschema-4.0.1.tar.gz 290999 BLAKE2B d693a33ef705a401187bdf603aacfd0336eab16afc0e38c5133ff6a74e4f0b323172d5abac0959163e40f546eedb75fe2b71f2ca53e7bbe1bf4f00ad977873b9 SHA512 50a2dd6423e8aca76e0a33e33a63bb7d1500abac891076426112c4577277d1f0322d06ec0ba5a9f47c65e5981f0cce768801e55e2f03ab6b0b6d2f884249b5fb
DIST jsonschema-4.1.0.tar.gz 306755 BLAKE2B a98f1050943543ac51a2e0a7242a8bab909805d660a21e13909748e847493fd7c1f513beb3dac1126e57ffd23bf6702bae52902a5ac6aa7ab94b39833fc40b0c SHA512 288c28d80dc3540386db8774783bbba67455cacd81232aa41e065a9b22fed85dc1bdddb955f8438735bef0f1eb2b2947ab07c66344adb486ef77b31b345f1182
DIST jsonschema-4.1.1.tar.gz 310026 BLAKE2B c14bee88d20c53e4198e58b946c92a5c505a205daa09c30c474c2e95af45414b1c527298a2e0df647acd79ccbe9344c2aa03ee3e1b7daafda76153248e73f794 SHA512 7afa1bffd9631a503277479595cc9ed9a58ecd0f8f9035a2b65e4005f9f58ff4f6fa968b5ca783aa22c4530fc4acc5e2ea1ef2f67b7f4f09f245e9a6f2b2c3bd
+DIST jsonschema-4.1.2.tar.gz 310016 BLAKE2B 16ec4f73a16980ec69e4c8e0d937726a6fcbf7ba0ba24dc9d76b5bf107b924fb3917927748e3dafacc0305322e9cb405daa83800dcfd5f2fcc63dbb8fe10a25a SHA512 5ab43602cfc2dfe07a8c733f01915b4961ee88ebb37723a7a3a6ee4793ddae4b4638abe77ac9d192158ae7634aacee0c58fa2959288ea0f83e3403d5f8b9f185
diff --git a/dev-python/jsonschema/jsonschema-4.1.2.ebuild b/dev-python/jsonschema/jsonschema-4.1.2.ebuild
new file mode 100644
index 000000000000..904fc6ee1ce0
--- /dev/null
+++ b/dev-python/jsonschema/jsonschema-4.1.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="An implementation of JSON-Schema validation for Python"
+HOMEPAGE="https://pypi.org/project/jsonschema/ https://github.com/Julian/jsonschema"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ >=dev-python/pyrsistent-0.18.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+ ' pypy3)
+"
+
+# formatter deps
+RDEPEND+="
+ dev-python/fqdn[${PYTHON_USEDEP}]
+ dev-python/idna[${PYTHON_USEDEP}]
+ dev-python/isoduration[${PYTHON_USEDEP}]
+ >=dev-python/jsonpointer-1.13[${PYTHON_USEDEP}]
+ dev-python/rfc3339-validator[${PYTHON_USEDEP}]
+ dev-python/rfc3986-validator[${PYTHON_USEDEP}]
+ dev-python/rfc3987[${PYTHON_USEDEP}]
+ dev-python/uritemplate[${PYTHON_USEDEP}]
+ >=dev-python/webcolors-1.11[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/twisted[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest