summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-11-05 11:33:18 +0100
committerJustin Lecher <jlec@gentoo.org>2016-11-05 11:35:46 +0100
commit1ba65cdc0162b073450fb4bcf30d1a3b8bd9d53b (patch)
tree1bea57e38f64cd3083f60a3532445a4ca8545b4d /dev-python/jupyter
parentmedia-sound/ncmpcpp: Update live ebuild. (diff)
downloadgentoo-1ba65cdc0162b073450fb4bcf30d1a3b8bd9d53b.tar.gz
gentoo-1ba65cdc0162b073450fb4bcf30d1a3b8bd9d53b.tar.bz2
gentoo-1ba65cdc0162b073450fb4bcf30d1a3b8bd9d53b.zip
dev-python/jupyter{,_core}: Backport patch to avoid File collision
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=589750 Package-Manager: portage-2.3.2 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/jupyter')
-rw-r--r--dev-python/jupyter/Manifest1
-rw-r--r--dev-python/jupyter/jupyter-1.0.0-r1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/jupyter/Manifest b/dev-python/jupyter/Manifest
index 4ba519e9300d..a84859b416ee 100644
--- a/dev-python/jupyter/Manifest
+++ b/dev-python/jupyter/Manifest
@@ -1 +1,2 @@
+DIST jupyter-1.0.0-file-colision.patch 1727 SHA256 a88e50d5aba792e87566c74991023017e04324f728f628b3e45b8ba05feb9140 SHA512 a6b4cc6b91bb9941f029963cc3e3b7f415192f64788a34dde7828d450497987f92c25655c5ca183a7408fb1fb439917ba0f0a1ef1db3fe3bec1fc46d9ad2cf4d WHIRLPOOL 3690b872d910ed8e4615780e868c566f1f36c84fa11c33b25f2b9380a7f201a5c99aae9e29a0e6fb068494ff32babb257f20f773c7af901f25226ac1fd40767d
DIST jupyter-1.0.0.tar.gz 12916 SHA256 d9dc4b3318f310e34c82951ea5d6683f67bed7def4b259fafbfe4f1beb1d8e5f SHA512 1f0bc83f7a127c98ccf4b3868814116aa272ea5d0baac52d7a022305af7e2da28ca2b90fa3554ff085d8df3eb6d8b8cde80bf02b8e66064c59900b926d73c520 WHIRLPOOL c648e494556f6d5d3a42594bb4c2fd5701b2f993cf467d6011f67141de2e80d6cccf1adfcfcda6445d8325604e67d6af4465b6e2d79443de67512a2a29360855
diff --git a/dev-python/jupyter/jupyter-1.0.0-r1.ebuild b/dev-python/jupyter/jupyter-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..c9c8404c2454
--- /dev/null
+++ b/dev-python/jupyter/jupyter-1.0.0-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter metapackage. Install all the Jupyter components in one go"
+HOMEPAGE="http://jupyter.org"
+SRC_URI="
+ mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ https://patch-diff.githubusercontent.com/raw/jupyter/jupyter/pull/198.patch -> ${P}-file-colision.patch
+ "
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+RDEPEND="
+ dev-python/notebook[${PYTHON_USEDEP}]
+ dev-python/qtconsole[${PYTHON_USEDEP}]
+ dev-python/jupyter_console[${PYTHON_USEDEP}]
+ dev-python/nbconvert[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/ipywidgets[${PYTHON_USEDEP}]"
+DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+PDEPEND=">=dev-python/jupyter_core-4.2.0[${PYTHON_USEDEP}]"
+
+PATCHES=( "${DISTDIR}"/${P}-file-colision.patch )
+
+python_prepare_all() {
+ # Prevent un-needed download during build
+ if use doc; then
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/source/conf.py || die
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( "${S}"/docs/build/html/. )
+ distutils-r1_python_install_all
+}