summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-02 10:43:58 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-02 11:12:01 +0200
commiteec9a7d4a6cd799cb09bfeb3591a09c438d9d2cf (patch)
tree8f6acd93572764f60e335e9c97ee08b2e65c0d60 /dev-python/jupyter_client/jupyter_client-6.1.6-r2.ebuild
parentdev-python/jupyter_console: Remove py3.6 due to ipython (diff)
downloadgentoo-eec9a7d4a6cd799cb09bfeb3591a09c438d9d2cf.tar.gz
gentoo-eec9a7d4a6cd799cb09bfeb3591a09c438d9d2cf.tar.bz2
gentoo-eec9a7d4a6cd799cb09bfeb3591a09c438d9d2cf.zip
dev-python/jupyter_client: Remove py3.6 in new rev due to ipython
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jupyter_client/jupyter_client-6.1.6-r2.ebuild')
-rw-r--r--dev-python/jupyter_client/jupyter_client-6.1.6-r2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/jupyter_client/jupyter_client-6.1.6-r2.ebuild b/dev-python/jupyter_client/jupyter_client-6.1.6-r2.ebuild
new file mode 100644
index 000000000000..85d8a9afd7bc
--- /dev/null
+++ b/dev-python/jupyter_client/jupyter_client-6.1.6-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_REQ_USE="threads(+)"
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter protocol implementation and client libraries"
+HOMEPAGE="https://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/async_generator[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+ dev-python/jupyter_core[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-14.4.0[${PYTHON_USEDEP}]
+ www-servers/tornado[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest